im new on this site so i hope im not making myself look super stupid (beside the fact that my english isnt that best)

I got myself a Raspberry Pi 4B with an 64GB SDCard of Sandisk Ultra. Installed on it is an Ubuntu server 20.04 ARM Version. It usually runs 24/7 in my local network for research and bit of education.

What happen:

After installing an Update with "Sudo apt update", "sudo apt upgrade" and finishing it with "reboot", i got stuck into initramfs.

The only message shown is:

Thu Jan 1 00:00:06 UTC 1970
writable:recovering journal
writable: superblock need_recovery flas is clear, but journal has data.
writable: Run journal anyway

          (i.e., without -a or -p options) 
fsck exited with status code 4
The root filesystem on /dev/mmcblk0p2 requieres a manual fsck

BusyBox v1.30.1 (Ubuntu 1:1.30.1-6ubuntu2) built in shell (ahs)
Enter 'help'for a list of built-in commands.


I did what it says to me and tried to run it manually with the command:

(initramfs) fsck /dev/mmcblk0p2
fsck from util-linux 2.36.1
e2fsck 1.45.7 (28-Jan-2021)
writable: recovering journal
Superblock needs_recovery flag is clear, but journal has data.
Run journal anyway<y>? yes
fsck.ext4: unable to set superblock flags on writable

writable: ********** WARNING: Filesystem still has errors **********

(initramfs) _

After some research i found out it were problably the sd card soo i tried to reeinstall the ubuntu server on it again.

But the sd card doesnt get wiped. not wiped in windows neither Linux. The files inside are set into read only, but trying to wipe it with sudo on an other device doesnt affect it in anyway. Trying to delete anything or make it writable on the initramfs gives me a "Permission Denied".

because all my data is already save i would like to wipe it. But im still curios why this happens because i had it twice. in the first time it got fixed easy by just reeinstalling. And this is the second time.

I hope some of u got any idea to fix it. I googled my way down and up, but didnt find anything.

  • Well i couldnt get any solution so i messaged SanDIsk cause i found out that alot of people got the same problem like me. Sounds like a hardware problem soo lets see if ican get my money back (i do have anoter SD Car which i use for now)
    – sefikkaan
    Commented Sep 16, 2021 at 20:24

1 Answer 1


I am also new (cannot comment) but have you tried dd Command (here is a link ) the sd card? maybe via virtual linux if you are running on win?

  • didnt tried it yet, i do it this evening and respond my result
    – sefikkaan
    Commented Sep 2, 2021 at 18:53
  • I tried formating it with the command: sudo dd bs=1M if=/dev/zero of=/dev/sdc1 but i get the error: dd: Error writing '/ dev / sdc1': There is no more storage space available on the device
    – sefikkaan
    Commented Sep 4, 2021 at 14:08
  • right command ... at least it was a try...
    – kamino
    Commented Sep 4, 2021 at 15:30

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .