1

I have a laptop with an extra internal HDD and external HDD via USB that I would like to automount using autofs. Here is my auto.master:

/mnt/ /etc/auto.ext-int
/run/media/ /etc/auto.ext-usb

Auto.ext-int, which is for the internal HDD, contains:

external        -fstype=auto    :dev/sda1

Auto.ext-usb, which is for the external HDD, contains:

8E7633617633496B        -fstype=auto    :/dev/sdb

The internal HDD seems to be automounting correctly now, although it seems to break easily when I stop the service multiple times to manually use the automount with automount -f -v. The latter refuses to mount. Here is what automount -f -v displays:

Starting automounter version 5.1.7-17.fc34, master map auto.master
using kernel protocol version 5.05
can't connect to sssd, retry for 10 seconds
can't connect to sssd, retry for 10 seconds
can't connect to sssd, retry for 10 seconds
mounted indirect on /misc with timeout 300, freq 75 seconds
mounted indirect on /net with timeout 300, freq 75 seconds
mounted indirect on /mnt with timeout 300, freq 75 seconds
mounted indirect on /run/media with timeout 300, freq 75 seconds
attempting to mount entry /mnt/external
mounted /mnt/external

fdisk -l displays this info about both drives:

Disk /dev/sda: 465.76 GiB, 500107862016 bytes, 976773168 sectors
Disk model: TOSHIBA MQ01ACF0
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 4096 bytes
I/O size (minimum/optimal): 4096 bytes / 4096 bytes
Disklabel type: gpt
Disk identifier: 7AF52ADD-7356-4437-B499-31359675DAC1

Device     Start       End   Sectors   Size Type
/dev/sda1   2048 976773119 976771072 465.8G Linux filesystem

Disk /dev/sdb: 931.51 GiB, 1000204886016 bytes, 1953525168 sectors
Disk model: 2115
Units: sectors of 1 * 512 = 512 bytes
Sector size (logical/physical): 512 bytes / 512 bytes
I/O size (minimum/optimal): 512 bytes / 512 bytes
Disklabel type: dos
Disk identifier: 0x6233580c

Device     Boot  Start        End    Sectors   Size Id Type
/dev/sdb1  *      2048     206847     204800   100M  7 HPFS/NTFS/exFAT
/dev/sdb2       206848 1953521663 1953314816 931.4G  7 HPFS/NTFS/exFAT

I am not sure why sdb cannot be mounted in this way. I can mount it with a GUI like Gigolo to /run/media/$USER/8E7633617633496B/ or through command line, but only if the autofs service hasn't ran. Even after stopping the service, I cannot mount the HDD without the error:

mount: /home: /dev/sdb already mounted or mount point busy.

Although df shows that it is clearly not mounted:

Filesystem     1K-blocks    Used Available Use% Mounted on
devtmpfs         8046936       0   8046936   0% /dev
tmpfs            8066544   20500   8046044   1% /dev/shm
tmpfs            3226620    1780   3224840   1% /run
/dev/nvme0n1p3 242534400 3548988 238084340   2% /
tmpfs            8066544     544   8066000   1% /tmp
/dev/nvme0n1p3 242534400 3548988 238084340   2% /home
/dev/nvme0n1p2    999320  242532    687976  27% /boot
/dev/nvme0n1p1    613184   16524    596660   3% /boot/efi
tmpfs            1613308      56   1613252   1% /run/user/1000

This is all very confusing at this point, any help would be appreciated.

EDIT: I receive this error when attempted to cd into the external HDD from automount:

attempting to mount entry /run/media/8E7633617633496B
>> mount: /run/media/8E7633617633496B: wrong fs type, bad option, bad superblock on /dev/sdb, missing codepage or helper program, or other error.
mount(generic): failed to mount /dev/sdb (type auto) on /run/media/8E7633617633496B
failed to mount /run/media/8E7633617633496B

It also seems that I was wrong and that my internal HDD is also not mounting automatically, it will only display in ranger if I cd into it. Otherwise it displays as empty. Trying this with the external HDD does not work at all.

7
  • Why are you using /run/media? That’s already a mount point used by udisks2.
    – jsbillings
    Aug 29, 2021 at 0:37
  • In the past whenever I have used a GUI program to mount it for me, it would always be in /run/media/$USER/. So I have tried doing something similar.
    – Sagarmatha
    Aug 29, 2021 at 0:42
  • That was udisks2. Unfortunately, it’s probably trying to also use the mount point, so you will encounter problems. Try some other path.
    – jsbillings
    Aug 29, 2021 at 0:44
  • I have tried using /mnt/ as well for both drives, but the same issue occurs, particularly the one in my edit. I am sure this is not the issue, but I will leave it this way to prevent any further errors. Thanks.
    – Sagarmatha
    Aug 29, 2021 at 0:52
  • you’re already using /mnt! Pick something else.
    – jsbillings
    Aug 29, 2021 at 0:53

2 Answers 2

0

The problem is that you are using /dev/sdb in your automount definition, which is the device name for the whole drive, not an individual partition. Pick /dev/sdb1 or /dev/sdb2, and it will mount.

Also, you are using /run/media as the mount point, which the udisks2 service also uses. It will create its own mount point on top of your autofs mount, depending on the order of services starting. Choose something other than /mnt or /run/media.

1
  • This seems to have fixed it, thanks!
    – Sagarmatha
    Aug 29, 2021 at 1:00
0

Even though your problem is evidently resolved, I had a not that much dissimilar issue. In my particular instance, external devices had suddenly stopped automounting. What I've determined is that some high_level formatting might be required. In my situation, I wound up using the mkfs command /dev/sdb. After that, I rebooted with the external usb device still plugged in. One of the first things that I noticed when the desktop opened was the immediate reappearance of the eject button in the taskbar. I had not seen that since the automount stopped working. And of course the drive reappeared in file manager as expected. As always before using any such command, make sure to backup any and all data that is still needed. The syntax; sudo mkfs.ext4 /dev/sdb. That last part may be sdb, sdb1 or whatever you determine whenever you run lsusb or sudo fdisk -l

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .