0

Am installing gentoo. At Grub bootloader but can’t seem to find kernel, which is odd because it’s existence was verified before restarting the machine. There doesn’t seem to be a “root” or “kernel” command, nor “vmlinuz”. Hexdumping gpt1 and gpt2 (the only two partitions with recognizable file systems to grub) says they’re not bootable disks.

Edit: Made some progress—found the vmlinuz and initramfs with “ls (hd0, partition)/“. Used “linux” command and initrd to set and handle boot. Used “boot” to boot. Oddly enough, the partition with the correct filesystem for boot seems to require a rescue shell.

Here are the instructions I’m following: https://christitus.com/grub-rescue/

3
  • 1
    Does your system use a classic BIOS or is it a UEFI system? There are major differences in the boot process between the two. If it's a UEFI system, please run efibootmgr -v as root and edit the output into your question. Also, please add a link to the instructions you're following or otherwise describe exactly what you're doing. Your talk about hexdumping partitions indicates you may be knowledgeable about BIOS-style boot process, but if your system is UEFI, much of that knowledge will no longer apply.
    – telcoM
    Aug 23 at 7:05
  • What does “mount all partitions” mean using the gentoo livecd? Don’t have to download a new tarball, right?
    – Linuxn00b
    Aug 24 at 19:07
  • youtu.be/AyZa8h68wbI
    – Linuxn00b
    Aug 24 at 19:25
1

Use this checklist to troubleshoot common booting problems [with Gentoo]:

  1. Ensure that your vmlinuz and initrd/initramfs are present on boot partition, not /boot directory on root filesystem.
  2. Boot with Gentoo Live CD, mount all partitions, chroot and regenerate Grub config with grub-mkconfig -o /boot/grub/grub.cfg (from chroot).
  3. Use parted or fdisk to enable ESP (EFI System Partition) flag on your boot partition. After this, reboot.
0
0

Hexdumping gpt1 and gpt2 (the only two partitions with recognizable file systems to grub) says they’re not bootable disks.

you can change the boot flag with gparted (sorry i don't know how to this with command line, but the answer is here: Set Bootable Partition Command Line)

2
  • Please add further details to expand on your answer, such as working code or documentation citations.
    – Community Bot
    Sep 4 at 23:00
  • i linked to a good answer because i can't comment... Sep 4 at 23:09

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.