0

Unlike Windows, I discovered that the speed of my Access Point is too slow about 50-70KB on Debian unlike Windows it is about 1.3MB which is the original full download speed of my connection.

Here are the interfaces I have:

PHY     Interface       Driver          Chipset

 phy0    ap0             ath9k           Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
 phy0    wlan0           ath9k           Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01)
 phy1    wlan1           rt2800usb       Ralink Technology, Corp. RT2870/RT30

Unlike Windows, since I cannot use Ralink Technology, Corp. RT2870/RT3070 as AP and STA in the same time, I used Qualcomm Atheros AR9285 Wireless Network Adapter (PCI-Express) (rev 01) yet It is slow.

How do I tweak the speed?

1 Answer 1

0

I have the same adapter build into my laptop. For me the solution was to disable a setting in my router (Telekom Speedport W724V)

Under the 2.4 GHz frequency band settings i unchecked the box "max. 300 Mbit/s". The manual states here:

With the max. 300 Mbit/s option, you can increase your WiFi's speed by increasing the useable channel bandwidth from 20 MHz to 40 MHz.

I guess you should try reducing your access points bandwith to 20MHz.

Hope it helps.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .