6

This question is a follow-up to this one, which remains unresolved.

My ProtonVPN connection keeps breaking. I'm using Ubuntu 18.04. Right now, in the broken state, the two ProtonVPN device profiles proton0 and ipv6leakintrf0 are listed as "unmanaged" and "disconnected", respectively, by nmcli:

$ nmcli d
DEVICE          TYPE      STATE         CONNECTION 
wlp3s0          wifi      connected     WifiAP
ipv6leakintrf0  dummy     disconnected  --         
enp2s0          ethernet  unavailable   --         
lo              loopback  unmanaged     --         
proton0         tun       unmanaged     --

ProtonVPN support has not been able to resolve the issue after working on it for nearly two months, but they did inform me they don't support unmanaged connections. So, I'm struggling on my own to make both proton0 and ipv6leakintrf0 be "managed".

From what I can piece together from the NetworkManager configuration documentation, NetworkManager configures devices from the following sources, in order:

  1. /usr/lib/NetworkManager/conf.d/
  2. /run/NetworkManager/conf.d/
  3. /etc/NetworkManager/conf.d/
  4. /etc/NetworkManager.conf
  5. /var/lib/NetworkManager/NetworkManager-intern.conf

Within the three directories, files are parsed in their listed order. On my system, the file /usr/lib/NetworkManager/conf.d/10-globally-managed-devices.conf exists and contains the following directive:

[keyfile]
unmanaged-devices=*,except:type:wifi,except:type:wwan

This appears to set all non-wifi and non-wan network devices to "unmanaged", which would explain why proton0 and probably ipv6leakintrf0 are unmanaged. However, given how poorly-designed the NetworkManager UX is, there's no way for me to be certain that subsequent configuration I don't understand isn't overriding this directive.

I searched the above configuration list for another unmanaged-devices directive and found none, so I can only assume the one in 10-globally-managed-devices.conf is the only one. In that case, it seems like I could correct the problem and make proton0 a managed device by creating a file /usr/lib/NetworkManager/conf.d/80-proton-vpn.conf with the following contents:

[device]
match-device=interface-name:proton0
managed=true

[device]
match-device=interface-name:ipv6leakintrf0
managed=true

where I've pieced the syntax together as best I can from the poor documentation linked above. I restarted network-manager. ProtonVPN worked for several days before breaking again, giving the $ nmcli d output shown above that indicates proton0 (and probably ipv6leakintrf0) are still unmanaged, despite my best efforts at changing the config.

This AskUbuntu answer indicates that the listing of a device in /etc/network/interfaces will cause it to be unmanaged by NetworkManager. In my case that does not apply, the only contents of that file are

$ cat /etc/network/interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
auto lo
iface lo inet loopback

What else do I have to do to make these device profiles be managed by NetworkManager?

2
  • 1
    Did you try to change the unmanaged-devices line by adding ",except:interface-name:proton*" ?
    – ktf
    Commented Aug 22, 2021 at 12:39
  • I had no idea I could do that. I tried it and restarted network-manager; nmcli d still shows 'proton0' as "unmanaged", so it didn't work. Commented Aug 23, 2021 at 12:02

2 Answers 2

1

Did you try to just comment that line? I think that it's just a configuration for dealing with netplan.

If works, it's better to override that file copying it to
/etc/NetworkManager/conf.d

Edit the file and set the directive to blank

unmanaged-devices=
1
  • It worked for me. Nice.
    – sequence
    Commented Nov 9, 2022 at 6:01
0

I had a similar problem with a Sierra Wireless RC7611 (for US) / RC7620 (for RoW) LTE module. Originally it worked fine:

# nmcli dev
DEVICE    TYPE      STATE         CONNECTION
cdc-wdm0  gsm       disconnected  --

but when we upgraded NetworkManager it stopped being managed:

# nmcli dev
DEVICE         TYPE      STATE         CONNECTION
wwan0          wwan      unmanaged     --

We are building our Linux kernel from Yocto. The change in package versions was because we moved from the Dunfell (3.1) version to Kirkstone (4.0). I didn't realise that the NetworkManager package configuration had been broken up (ref https://patchwork.yoctoproject.org/project/oe/patch/[email protected]/#1783). We now have to explicitly add the package networkmanager-wwan so NetworkManager will recognise the Sierra RC7611/RC7620:

# nmcli dev
DEVICE    TYPE      STATE         CONNECTION
cdc-wdm0  gsm       disconnected  --

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .