After installing Ubuntu 20.04 LTS I had an issue with my earphones. Initially my mic and my earphones both weren't working. But after a bit of research I was able to fix the speakers but mic is still an issue.

I determined the codec with

$ cat /proc/asound/card*/codec* | grep Codec
Codec: Realtek ALC662 rev3

Then after knowing the codec of my sound card I visited the kernel documentation and picked up my model and added the following line in /etc/modprobe.d/alsa-base.conf:

options snd-hda-intel model=alc662-headset-multi

This fix seemed to work when I selected Analog Stereo Duplex(unplugged) in Pavucontrol and the audio came in speakers but mic was still dead but somehow it was able to capture all the voices coming out of speaker of headphone. I went to settings but there was no option to select input device device.

Screenshot of my System Settings

I installed a audio recorder and there I could find an option to select external mic and it worked quite well.

enter image description here

How to fix this problem? I am unable to access mic in any other application

Additional Notes: enter image description here The problem is in front panel only, rear mic and speaker works. My PC is very old so I have two separate jacks for mic and speakers.

1 Answer 1


It seems like your mic is recognised by the OS, but is not set as the default device for input. You should change default mic and related settings with the pavucontrol package. It is a package that lets you easily switch streams of audio if you use pulseaudio or pipewire.

  • I have already tried. It's written in question Aug 20, 2021 at 10:23

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .