0

So, earlier I had Windows 7 on my laptop. I deleted all the Partitions and I think deleted the efi paritition too(which maybe shouldn't be deleted?).

I boot into LM on my Live Disk and automatically installing using the option 'Erase Disk and Intall Linux Mint', I receive this error: 'Failed to Install Grub. Fatal Error.'

I saw it on a LM Forum, and generated a boot report by these commands:

sudo add-apt-repository ppa:yannubuntu/boot-repair
apt update
apt install -y --install-recommends boot-info
boot-info

And I get this:

Boot Info Summary

=>No boot loader is installed in the MBR of /dev/sda.

sdb:

File system:

iso9660 Boot sector type: Unknown

Boot sector info:

Mounting failed: mount: /mnt/BootInfo/FD/sdb: /dev/sdb already mounted or mount point busy.

0 os detected

Architecture/Host Info

CPU architecture: 64-bit

Live-session OS is Linuxmint 64-bit (Linux Mint 20.2, uma, x86 64)

UEFI

BIOS is EFI-compatible, and is setup in EFI-mode for this live-session.

efibootmgr -V

Timeout: 10 seconds.

No BootOrder is set; firmware will attempt recovery This session has been detected as 'live' because /proc/cmdline contains (boot-casper)

This session has been detected as 'live' because df -Th / contains overlay

I don't understand this, except one that, I have created a GPT Partition Table from Gparted but this:

No boot loader is installed in the MBR of /dev/sda.

so maybe this could be the issue.

I read somewhere that this could be due to a missing efi partition, so I used 'Something else' during LM Installation and created a 500mb efi Partition and another partition formatted as EXT4 mounted at /. And it works! I don't get the error this time during installation but when I restart to boot into the installed OS, I just see a blank screen, I don't even see the GRUB menu.

I tried installation on Debian too, but I get the same error: 'Failed to Install Grub. Fatal Error.' and I didn't try manual partitioning as it doesn't have Gparted and I'm a bit new.

This is an old laptop from 2011 and the bios doesn't have any option for 'Safe Boot' or 'Secure Boot and also it doesn't have 'Legacy USB boot for EFI systems' setting. The BIOS doesn't have any Legacy or UEFI settings

Most answers on forums, AskUbunu, and SuperUser are about Dual Booting and are very complex.

4
  • How you boot install media UEFI or BIOS is then how it installs. If you installed grub to ESP, you have to have booted in UEFI boot mode. Very early/old UEFI may not have had Secure Boot or it may be called "Other" and "Windows". If drive is gpt partitioned & you install in BIOS/CSM mode, you must have a bios_grub partition for grub. Best to post link to Boot-Repair's summary report to see the full report.
    – oldfred
    Aug 20 '21 at 3:43
  • You mean the summary from boot-info, right ?
    – Mayank
    Aug 20 '21 at 4:00
  • "BIOS is EFI-compatible, and is setup in EFI-mode for this live-session." That means I probably installed in UEFI. I was just reading online, I didn't set Flags for the efi partition, could that be the cause of the issue?
    – Mayank
    Aug 20 '21 at 4:04
  • Yes, the EFI partition needs a particular partition type identifier, which is represented as the ESP flag in GParted and other partitioning tools based on it.
    – telcoM
    Aug 20 '21 at 9:17
0

You cannot install GRUB if you don't have a EFI System partition (ESP) and your system boots in EFI mode. ~200MB for it would be enough. It must be formatted to FAT32 (FAT16 will also work but FAT32 is slightly more reliable).

As for flags, please refer to Do you need to set bootable Flag when Installing Linux in UEFI Mode?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.