4

I've been having this issue for at least 3 years where my display will be blurry while using the proprietary Nvidia driver. Nouveau doesn't fix anything either.

Any screenshots that I take using the monitor will show up crystal clear, but visually looking at it, everything seems fuzzy, blurry and sometimes even ghosts if I move a window around. I have a second monitor plugged in via a DP->VGA adaptor and, even when my main monitor is blurry, that looks perfectly fine. Sometimes my monitor will work flawlessly, but that's once in a blue moon.

I'm currently running Void Linux with the latest Linux kernel and KDE Plasma.

I am using an Nvidia RTX 2060, and the monitor is getting the signal via HDMI. I am unsure of the monitor's control board and anything like that as it's a seemingly random brand that have no official datasheets (and it doesn't even seem to be sold anymore). What I do know is it's a 32" 1080p@60Hz display, and it won't go higher than that.

I don't have this issue on Windows 10, and everything is displayed crisp and clear as day.

Here are some steps I have taken:

  • Tried GNOME, KDE Plasma and even XFCE - all produce the same output
  • Swapped the HDMI cable and even bought a whole new one
  • Tried changing the HDMI port that I use on the monitor
  • The issue has persisted across two GPUs now (I used to use a GTX1050)
  • Reinstalling the Nvidia Linux drivers (and reconfiguring them). They show up in lsmod and X11 is set to use them - nouveau is blacklisted and I confirmed this with lsmod
  • The issue has persisted over many distros, such as Ubuntu, Pop, Arch, Gentoo and Void.
  • I have looked in the monitor settings and found nothing relevant, and changing everything I can see does nothing to fix the clarity either
  • I've looked high and low in Plasma's and Nvidia's settings, and tried things such as forced anti-aliasing, text rendering, and even vsync changes. They make no difference even after a save + reboot.
  • I've installed every (even seemingly) relevant package across every Linux distribution that I've used, and none of them made a difference.
  • I re-tried POP_OS and ensured that I was using the Nvidia ISO and installs to root out any misconfiguration, to no avail.
  • Ensured that FXAA was disabled in the Nvidia settings
  • I can view this image found by @ArtemS.Tashkinov in Firefox while using F11, with no vertical/horizontal scroll bars
  • I have checked through the nvidia log file (the one you're able to generate manually) and found nothing that seems to relate to my issue.

It's probably important to note that, in a live Linux ISO, if I change my output to a lower resolution and then back to native a good 5-8 times, the monitor will clear up. This is not a permanent fix but I think it has something to do with the connection being re-initialised, although I'm not too sure about the reason.

Another odd thing I have noticed is that, occasionally, on first boot the monitor will look perfectly fine (as it does on Windows). If the monitor goes into standby mode and turns back on however, things go back to the usual blurry state.

I have looked around for others that have experienced something similar to me and all of the issues turned out to be misconfiguration or things that had nothing to do with what I'm experiencing (mostly anti-aliasing issues).

I find it hard to think of things that could be at fault as it works perfectly fine in Windows, which is baffling to me. In addition to this, when I ran Windows under Linux via KVM+QEMU (with Single GPU Passthrough), all the issues went away as the drivers were handled by Windows.

Here is an output of xrandr:

Screen 0: minimum 8 x 8, current 3360 x 1179, maximum 32767 x 32767
HDMI-0 connected primary 1920x1080+1440+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1920x1080     60.00*+  59.94    50.00    23.98  
   1680x1050     59.95  
   1440x900      59.89  
   1280x720      60.00    59.94    50.00  
   1152x864      60.00  
   1024x768      60.00  
   800x600       60.32    56.25  
   720x576       50.00  
   720x480       59.94  
   640x480       75.00    72.81    59.94    59.93  
DP-0 connected 1440x900+0+279 (normal left inverted right x axis y axis) 408mm x 255mm
   1440x900      59.89*+
   1280x1024     75.02    60.02  
   1280x960      60.00  
   1152x864      75.00  
   1024x768      75.03    70.07    60.00  
   800x600       75.00    72.19    60.32    56.25  
   640x480       75.00    72.81    59.94  
DP-1 disconnected (normal left inverted right x axis y axis)
DP-2 disconnected (normal left inverted right x axis y axis)
DP-3 disconnected (normal left inverted right x axis y axis)
DP-4 disconnected (normal left inverted right x axis y axis)
DP-5 disconnected (normal left inverted right x axis y axis)

Here are two previews of google.com, this is windows and this is Linux. I know the differences aren't too perceivable on camera, but they are to the naked eye. Looking at it more, it seems that the output is also heavily under-saturated while in Linux.

Just as an additional comparison, I ran this sharpness test on both Windows and Linux. Here is Windows, and here is Linux.

I'm completely out of ideas now, so any help or insight as to how I'd go about even debugging this would be greatly appreciated!

I have also asked this question on the Nvidia Linux forums, as suggested by a commenter, but have had zero help there.

11
  • Check the screen configuration (not the system one, the firmware one). Windows might be compensating a value in software, while Linux leaves it as is (or the other way around, with Linux getting it wrong). I also suggest you boot a couple of live systems and see what happens. Commented Aug 17, 2021 at 19:45
  • The issue has persisted across two GPUs now - this could be an issue with your monitor, maybe its EDID data is corrupted. Are you sure you're using the monitor at its native resolution? Can you post xrandr output? Also it would be nice to see the actual photos or your monitor running in Windows and Linux if possible. E.g. open google.com in both. Commented Aug 17, 2021 at 19:46
  • @EduardoTrápani Sadly, I've tried another screen. My second monitor is connected and even when my main one is fuzzy, the second one looks fine. Usually in live systems (I'm referencing the Cinnamon-Void ISO here) if I change the resolution to something lower and than back to native a good 6 or so times (to get my monitor to re-initialise the connection(?) i think), it'll clear up. These changes aren't permanent, but I should probably mention that in my main post.
    – brxken
    Commented Aug 17, 2021 at 19:48
  • There's something wrong with your Linux picture - that's for sure. Have you taken pictures from the same distance? It looks like your monitor is actually running at different resolutions on different OSes. Sorry, I've no idea what's going on. Please repost your question here: forums.developer.nvidia.com/c/gpu-graphics/linux/148 Commented Aug 17, 2021 at 20:59
  • @ArtemS.Tashkinov The pictures were taken from roughly the same distance, although I did crop the Windows one to cut out any unnecessary area. I double checked and both Windows+Linux are supposedly running at 1080p, 60Hz. I will repost my issue there and hope for the best. Thank you!
    – brxken
    Commented Aug 17, 2021 at 21:11

1 Answer 1

0
+50

Try:

  1. Change the permanent resolution
  2. On and off 3d acceleration
  3. "Vesa" video driver instead of nvidia and nouveau.
  4. Every kernel driver(module) has it's own parameters. See modinfo nvidia output for example("parm" records). Load your driver with different "parms" I can't recommend you particular ones. But anyway, just play with it some time.
  5. Install this nvidia drivers. Or kind of it with version 390 from your distro repository. It is the Nvidia drivers for old video cards. You can have a driver for modern cards only.
1
  • 1
    I have played around with these, rebooting between attempts and I'm not too sure what fixed it, but it was one of these, or maybe a combination! I changed 3d acceleration to off, downgraded the drivers and it's worked somehow! Thank you :)
    – brxken
    Commented Aug 28, 2021 at 12:46

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .