I'm here on an Ubuntu 12.10 Dell machine. Every 8.5 minutes packets get dropped, I don't lose the connection completely but for some seconds, no connections are successful. I had this problem before and it vanished but now it's back again.

I started to monitor all packages with Wireshark and first suspected that an unusual high number of ARP requests somehow DDOS my connection but this does not seem to be the problem. I started to ping a host on the Internet and charted the ping requests and responses and it's absolutely periodic, so I suspect it must be something with my system.

I can figure out if DNS resolution does not work, I don't get an address via DHCP or the routes are set up incorrectly but I have no idea where to start looking in this case. (I obviously tried Google)

Where could I start looking for problems? Kernel log doesn't show anything. Is there a buffer for incoming data that could overflow? Any tables in the kernel that could be purged periodically?

I forgot to add, the machine is connected to a switch under my desk. I also have a windows machine which is connected to the same switch and does not have any problems. Also I plugged the Linux box directly into the socket in the wall and I had the same problems.

Additional information

As far as I understand the dump, the connection are not reset, they just time out. I get a lot of tcp retransmission requests.

The ARP requests come from network crawlers which try to discover devices. While they sometimes sent up to 1000 requests for an IP address that does not exist, I could not see a correlation between those bursts and my failing connections. Also the activity of the crawlers are not periodic while my connections always fail after exactly the same time (about 8.5 minutes) so I ruled them out. I could so far not detect other unusual traffic.

As I said, I unplugged the linux box and plugged it directly into the network socket in the wall, without the IP phone and the switch in between and the behaviour is exactly the same. Therefore I don't think it's a problem with the equipment.

I gave up
I reinstalled Ubuntu and now it works normally again.

closed as too localized by Michael Mrozek Apr 17 '13 at 19:36

This question is unlikely to help any future visitors; it is only relevant to a small geographic area, a specific moment in time, or an extraordinarily narrow situation that is not generally applicable to the worldwide audience of the internet. For help making this question more broadly applicable, visit the help center. If this question can be reworded to fit the rules in the help center, please edit the question.

  • This could be a problem with your network equipment. Do other machines on the same network segment experience a similar problem? Are connections within the local link affected? Are TCP connections reset, or is there just a delay to IP packets? – Gilles Feb 28 '13 at 23:56
  • Who is sending ARPs, which address is being requested? Is this when the network is OK or when it is borked? Any other unusual traffic? – vonbrand Mar 1 '13 at 0:56
  • Check your cabling, too. – Deer Hunter Mar 1 '13 at 2:01
  • Closing since this has no answers and the OP gave up on solving it – Michael Mrozek Apr 17 '13 at 19:36

Browse other questions tagged or ask your own question.