1

i think its a newbie question, i try to create a nested lvm or stack lvm. so i try to create a pv out of a lv, but i just get this message:

pvcreate /dev/SSD-Pool/raid1-ssd

Cannot use /dev/SSD-Pool/raid1-ssd: device is not in a usable state

root@node01:/dev/SSD-Pool# lvs -a
  LV                   VG       Attr       LSize   Pool      Origin Data%  Meta%  Move Log Cpy%Sync Convert
  base-101-disk-0      SSD-Pool Vri---tz-k  50.00g fast_thin
  base-105-disk-0      SSD-Pool Vri---tz-k  50.00g fast_thin
  fast_thin            SSD-Pool twi-aotz-- 600.00g                  23.42  22.24
  [fast_thin_tdata]    SSD-Pool Twi-ao---- 600.00g
  [fast_thin_tmeta]    SSD-Pool ewi-ao----  76.00m
  [lvol0_pmspare]      SSD-Pool ewi------- 112.00m
  raid1-ssd            SSD-Pool Rwi-a-r--- 223.56g                                         100.00
  [raid1-ssd_rimage_0] SSD-Pool iwi-aor--- 223.56g
  [raid1-ssd_rimage_1] SSD-Pool iwi-aor--- 223.56g
  [raid1-ssd_rmeta_0]  SSD-Pool ewi-aor---   4.00m
  [raid1-ssd_rmeta_1]  SSD-Pool ewi-aor---   4.00m
  vm-100-disk-0        SSD-Pool Vwi-aotz-- 120.00g fast_thin        84.50
  vm-102-disk-0        SSD-Pool Vwi-aotz--  50.00g fast_thin        48.69
  vm-103-disk-0        SSD-Pool Vwi-a-tz-- 100.00g fast_thin        1.64
  vm-104-disk-0        SSD-Pool Vwi-aotz--  10.00g fast_thin        92.72
  Backup               Stuff    -wi-ao---- 500.00g
  base-102-disk-0      Stuff    Vri---tz-k  50.00g myStuff
  base-108-disk-0      Stuff    Vri---tz-k  50.00g myStuff
  base-110-disk-0      Stuff    Vri---tz-k  50.00g myStuff
  [lvol0_pmspare]      Stuff    ewi------- 104.00m
  myStuff              Stuff    twi-aotz--  <6.35t                  3.10   11.91
  [myStuff_tdata]      Stuff    Twi-ao----  <6.35t
  [myStuff_tmeta]      Stuff    ewi-ao---- 104.00m
  vm-100-disk-0        Stuff    Vwi-aotz-- 120.00g myStuff          20.30
  vm-104-disk-0        Stuff    Vwi-a-tz--  50.00g myStuff          7.62
  vm-104-disk-1        Stuff    Vwi-a-tz--  50.00g myStuff          11.65
  vm-105-disk-0        Stuff    Vwi-a-tz-- 100.00g myStuff          20.42
  vm-106-disk-0        Stuff    Vwi-a-tz--  10.00g myStuff          100.00
  data                 pve      twi-a-tz--  59.66g                  0.00   1.59
  [data_tdata]         pve      Twi-ao----  59.66g
  [data_tmeta]         pve      ewi-ao----   1.00g
  [lvol0_pmspare]      pve      ewi-------   1.00g
  root                 pve      -wi-ao----  27.75g
  swap                 pve      -wi-ao----   8.00g



pvcreate -vvvv output

Any Idea how to troubleshoot or proceed? Thanks!

4
  • 1
    Please add lvs -a output to your question and try running pvcreate with -vvvv to get more information. Also if this is a newly created RAID logical volume it's possible the initial resync is still in progress so the LV cannot be used. Aug 14 at 10:52
  • Yep. Attribute item 1, "(R)aid without initial sync"
    – steve
    Aug 14 at 11:12
  • 1
    Hi Thanks for your replay. I added the information. Its syncing, will try it again, after it finished.
    – Mr.Game
    Aug 14 at 11:21
  • Even after 100% sync, its the same error, i would be really thankful if somebody could just check the new output: pastebin.com/UnFXtGiE or give me some hints, how i could proceed. –
    – Mr.Game
    Aug 14 at 13:50
1

Most likely, you need to enable the scan_lvs option in your /etc/lvm/lvm.conf

If this still doesn't work, the device might be filtered out, in which case you might need to tinker with the filter option.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.