0

I installed Dolphin successfully, its icon is in ApplicationSystem Tools and it works well.

But, in SettingsDetailsDefault Applications there's everything else just not File Manager. Why this? Isn't managing files one of the main task`s on a desktop OS? And aren't personal file handling preferences as numerous as different OSs?

I found:

but those didn't help me in my case. How can I achieve this somehow else?

1 Answer 1

1

Found this here

Install xdg-desktop-portal and xdg-desktop-portal-kde.

Open the terminal and run the commands:

xdg-mime default org.kde.dolphin.desktop inode/directory

xdg-mime default org.kde.dolphin.desktop inode/directory application/x-gnome-saved-search

Insert the option to the file defaults.list:

echo "inode/directory=org.kde.dolphin.desktop" >> $HOME/.local/share/applications/defaults.list

Run the command sudo nano /etc/environment and insert GTK_USE_PORTAL=1;

Restart your computer.

1
  • 1
    I fixed your comment. No need to modify the root's default.list, he can define the user's default.list. Remember you need to clear the caches and the cookies. I am the author of the tutorial.
    – Oo'-
    Commented Feb 18, 2022 at 21:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .