0

I have three linux machines, one at work (desktop 'D') and two at home (laptop 'L', raspberry pi 'R'). I want to transmit data from my work machine to one at home. The data transmission in question is only ever outbound from work.

  1. I can access the desktop D from L, when I connect to my work VPN.
  2. When the VPN is connected, and I am remotely logged into the desktop, I cannot send any data from D -> R. The VPN connects L <-> D.
  3. when I disconnect the VPN, connections from D -> R work. (e.g. if I set a sleep command before trying to open a connection, and in that time, disconnect the VPN)

This situation is rather annoying as I cannot debug interactively. And what I find most strange is that the VPN connection is not between the machines that are communicating!

I have admin rights on the 3 machines. I have some control over the local router, including port forwarding. I have no control over the servers/VPN frontend etc at work.


Which machine is badly configured? Is it normal for VPNs to have side effects to other machines on the same network? What am I doing wrong?

nodes in the problem

3
  • can you provided us with an edited routing table of D when VPN is ON and when VPN is OFF ? maybe along with a traeroute -p 1234 123.1.2.3 from D in both state of VPN (ON/OFF) ?
    – Archemar
    Aug 9 '21 at 12:14
  • this is embarrassing, after struggling with this for 4 days before asking, the problem has now disappeared. I did a system upgrade without thinking about it, and the error no longer manifests. The upgrade included networkd-dispatcher and a bunch of samba packages that seem unrelated. I'm not sure the new info will help since the problem is gone.
    – Bonlenfum
    Aug 9 '21 at 15:35
  • no need to be embarraced, the most important thing is that problem is solved. However we should now close question as "unreproductible"
    – Archemar
    Aug 10 '21 at 7:07
0

Sounds like your laptop tries to route all traffic through VPN. If you are using GUI to set up the VPN to there should be an option similar to Use this connection only for resources on network on Ubuntu.

1
  • thanks for the suggestion. The only option I have is "Allow LAN access when using VPN", but it is already selected. As I commented on the question it seems that an old package on my laptop could have caused the problem - but I'm not going to install the old ones just to check since I have a working network finally!
    – Bonlenfum
    Aug 9 '21 at 15:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.