1

How can I disable GTT on amdgpu?

According to https://www.kernel.org/doc/html/v4.20/gpu/amdgpu.html, adding amdgpu.gttsize=0 should work but that has no effect.

The reason why I am asking is, that my Vega 8 graphics (of my AMD Ryzen 7 PRO 5850U cpu) already has 4GB VRAM and takes another 4GB of GTT. As the GTT memory is cut off from my "regular" 16 GB memory but I mainly use my CPU over my GPU (compiling, databases...), I only can use 12GB of it.

3
  • I'm having the same issue. The only thing I could do was reduce the "UMA Frame Buffer" size in the BIOS to 1GB (which appears to be the minimum). It was set to auto but was taking more than 5GB which lead my linux OS to have only 11GB of available ram (from 16GB)
    – andrepcg
    Aug 14 at 18:40
  • Probably just a checkup: Did you run update-grub after adding that gttsize to /etc/default/grub? Aug 14 at 19:39
  • 1
    Also, did you rule out your UEFI BIOS settings? Aug 14 at 19:42
1

I'm afraid your integrated vga has no ram. Based on https://askgeek.io/en/cpus/AMD/Ryzen-7-PRO-5850U : Transistor count 4,940 million .... Try the vramlimit instead of gtt.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.