3

I've been using the Meta/Super/Win key regularly to open the application launcher, but also as a modifier key in shortcuts. Now, all of a sudden it stopped working, as in hitting does not register at all. It does not open the application launcher, even though Alt+F1 is set as a shortcut and none of the shortcuts that it is a part of work anymore. So, I am assuming that something simply blocked it, but I don't know what.

I've tried searching for similar problems, but what I found seemed to have a slightly different problem and none of the suggestions I found made any difference. :(


Update: I've found a similar question where the OP tried using showkey. Apparently if I run showkey, the superkey does not trigger anything. I tried the suggested fix in that question, that is Fn+super to "restore" functionality, but it didn't do anything.

However, I noticed that now the CapsLock is also not working, but that actually shows up in showkey. Uh, and another strange thing is that CapsLock seems to trigger TAB behaviour, even though it shows up with a different number than TAB.

Is there a way just to reset the keyboard. (I did not knowingly do anything to it...)

3 Answers 3

3

OK, I figured it out and I will record it here and hopefully remember next time, because now that I know the answer I remember that this has happened to me before...

Anyway, here it is: apparently Fn+F6 seems to disable the superkey. Hitting it again re-enables it, so it's a toggle. The weird part is that my keyboard does not show anything for what the secondary function of the F6 key would be. All the F keys, except for F6 and F7 do something like volumes, turning wifi on/off, lighting, changing to an external screen, etc, but those two do not seem to have any other functionality. Well, except to screw with the super-key....

5
  • it may be the keyboard itself ... what make and model?
    – jsotola
    Commented Aug 8, 2021 at 2:51
  • It's a dell alienware laptop, but I think I've seen this behavior on an earlier machine, which come to think of it was also an alienware, so it is possible that this is a dell internal thing for these laptops... Commented Aug 8, 2021 at 3:04
  • the dell site has a list of alienware keyboard mappings ... Alt-F6 extends the desktop in some ... maybe the super key is functioning on an invisible part of the desktop
    – jsotola
    Commented Aug 8, 2021 at 3:33
  • interesting idea, but it is not Alt-F6, but Fn+F6, and after it is engaged, the superkey does not register on "showkey" or "xev". If it were acting anywhere, hitting it would be recognized, no? Commented Aug 8, 2021 at 7:54
  • 1
    Thanks for this hint. For me it was not F6, but the function on F12. It seems like this is a functionality limited to some keyboards only, As in my 20 year history of using computers this new HP Omen 15 laptop is the first to have this. There is an actual icon on the F12 key, depicting a lock next to the windows icon. Hope this helps someone.
    – ak93
    Commented Mar 8, 2023 at 18:16
0

I personally had a similar problem, where the solution was to disable the 'sticky keys' option in accessibility menu. Actually, it is disabled by default. I just had enabled it and forgotten to disable it again.

0

On Eluktronics, it's Fn+F2 . On Windows too! Was driving me crazy.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .