2

Everytime I run man it returns an error as if no man page entries were installed. Here's an example:

% man man

No manual entry for man

However, I have installed the packages man-db and man-pages, yet it doesn't return a single entry. I have tried with many commands like man ls, and others.

Also, if i run whatis man, the following is returned:

man: nothing appropriate.

10
  • man --debug man may output some useful information.
    – fra-san
    Aug 6, 2021 at 13:50
  • man -u man should try to rebuild the cache. Aug 6, 2021 at 13:53
  • I tried both, still it says no manual entry for man. Aug 6, 2021 at 13:58
  • @fra-san, the output shows the configuration at /etc/man_db.conf. Aug 6, 2021 at 14:01
  • 1
    @Procer.Scvtvlatvs On a regular Arch, the fundamental man pages are installed in /usr/share/man. As expected, your man config lists that one among the directories to search, but then it doesn't add it to the search path, as if it wasn't readable. Oddly, strace shows that man doesn't even try to access it. I can't come up with any plausible explanation, unfortunately.
    – fra-san
    Aug 6, 2021 at 15:22

1 Answer 1

4

Once you install the packages man-db and man-pages you need to run the mandb command to generate the search database for manpage entries.

EDIT (thanks to @fra-san): If you set the MANPATH environment variable, you also need to unset it. If that variable is set, man ignores the paths specified in the config file man_db.conf.

2
  • 2
    Thank you very much, that solved it. I also had to unset MANPATH so that mandb could use the man_db.conf settings. Aug 6, 2021 at 16:54
  • 1
    Adding the line unset MANPATH in my .zshrc, then source ~/.zshrc solved it for me too. Thank you!
    – kohane15
    May 6 at 8:28

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.