2

Refer to the document:

Prefixing a time variable with ‘t:’ will convert it to a string, so if ‘#{window_activity}’ gives ‘1445765102’, ‘#{t:window_activity}’ gives ‘Sun Oct 25 09:25:02 2015’. Adding ‘p (’ ‘t/p’) will use shorter but less accurate time format for times in the past. A custom format may be given using an ‘f’ suffix (note that ‘%’ must be escaped as ‘%%’ if the format is separately being passed through strftime(3), for example in the status-left option): ‘#{t/f/%%H#:%%M:window_activity}’, see strftime(3).

My tmux version is 3.1c. {t:window_activity} showed the correct time format, but {t/p:window_activity} and {t/f/%%H#:%%M:window_activity} showed empty. Are there additional settings needed to make the custom time format work properly?

1 Answer 1

2

It is a mistake to use documentation that does not correspond to your release. The man page for 3.1c does not mention these options, because they were not implemented until 3.2.

You can browse the source man page on github; it has the latest documention and line 4746 shows the options. Clicking on blame will show the origin of this line here (beware heavy page for browser), and clicking on the left url brings us to the change here, where the tag shown is 3.2.

So, to avoid problems, please use man tmux provided with the release in use, rather than just pages found on the internet.

1
  • Thank you! I didn't notice the version of the document!
    – IvanaGyro
    Commented Aug 7, 2021 at 8:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .