0

I am trying to get a modern Linux up and running on an elderly PC with a Vortex86DX CPU (i586) and a built-in GPU which is reported in dmesg as

[   21.246156] Console: switching to colour frame buffer device 100x37
[   21.256977] sisfb: 2D acceleration is enabled, y-panning enabled (auto-max)
[   21.257003] fb0: XGI Z7 frame buffer device version 1.8.9
[   21.257017] sisfb: Copyright (C) 2001-2005 Thomas Winischhofer

To my understanding this GPU was supported by the SIS module, but when trying to run startx the XGI driver is attempted, fails, and then the fbdev driver is used:

[  2994.516] (==) Matched xgi as autoconfigured driver 0
[  2994.516] (==) Matched modesetting as autoconfigured driver 1
[  2994.516] (==) Matched fbdev as autoconfigured driver 2
[  2994.516] (==) Matched vesa as autoconfigured driver 3
[  2994.516] (==) Assigned the driver to the xf86ConfigLayout
[  2994.517] (II) LoadModule: "xgi"
[  2994.532] (WW) Warning, couldn't open module xgi
[  2994.532] (EE) Failed to load module "xgi" (module does not exist, 0)

The fbdev driver does its job but is rather slow. The VideoDriverFaq at https://wiki.freedesktop.org/xorg/VideoDriverFAQ/ mentions that the sis driver should be used but it is clearly not properly autodetected. The sis module is available in a package and installed on the system

Output from lspci is:

meter1:~# lspci|grep VGA
00:03.0 VGA compatible controller: XGI Technology Inc. (eXtreme Graphics Innovation) Z7/Z9 (XG20 core)

How should I approach this?

5
  • 1
    First step is to write your own xorg.conf to force using the driver (google on how to do this). However, a lot of old X drivers have been deprecated, so I woulnd't be surprised if the sis driver no longer works with modern X. Of course you still can use a modern Linux with an old X, but then you'd probably have to compile from source (which isn't easy, and I've no experience compiling stuff under Alpine, which will probably need extra effort because of its libc etc.)
    – dirkt
    Aug 5 at 17:08
  • As first step, please post the output of lspci | grep VGA in order to figure the exact model of video card. Anyway, appears that xgi video cards are managed by xf86-video-sis. Another thing I would do is apk add xf86-video-sis and check if the module is loaded looking at xorg log file. If it's loaded, let me know and we can make a working xorg.conf together. Sadly I don't have an xgi card where I can test this. Aug 12 at 7:00
  • @FrancescoColista This is a v3.14.1 non-edge install, and I cannot locate the lspci command in neither main nor community. I have tried adding the sis video driver but it did not provide the xgi module. Aug 12 at 15:33
  • @FrancescoColista Found out how to install pciutils from edge using stackoverflow.com/a/52903112/53897 -output added to question. Aug 13 at 10:21
  • ok, FYI lspci is inside the package pciutils which is available in Alpine Linux also in 3.14.1. If you want to know how to search for a file in apk packages, you may want to check this link: unix.stackexchange.com/questions/307167/… Also, when you say "I have tried adding the sis video driver but it did not provide the xgi module", if you want help please indicate the steps that you have followed, the logs of Xorg, and the errors you get. Aug 13 at 12:38
-1

Usually nowadays Xorg is pretty able to auto-configure itself in the best way. Likely it is not the case... maybe an old Xorg package version, driver or weird hardware or better a combination of them cause the issue.

In these cases you have to help Xorg by manually configure the proper .conf file/s.

I link you a guide. It's for Arch Linux but you can easily use it as starting guide for your system.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.