0

I have a measurement device (an Agilent frequency counter) that I want to communicate with directly via it's LAN interface. However, my Ubuntu 20.04 laptop does not seem to want to establish a connection. I'm afraid there is some basic networking concept that I am not applying.

What I've tried: I've tested the device's LAN connection with a couple Windows PC's, and they connected (nearly) automatically. Curiously, when connected to my Ubuntu machine, the device still self-reports a fully functional LAN connection, and even displays its DHCP-assigned IP address. However, my laptop's wired network status oscillates between off and "Connecting", but never connects. Pinging the device's IP results in 100% loss. Yet more curiously, I am able to successfully connect to the device through a Windows VM on my Ubuntu machine.

My only lead is that the ip route show line for the device's network prefix is:

169.254.0.0/16 dev wlp0s20f3 scope link metric 1000

where I would expect the ethernet device here, not the wlan.

Any pointers are very appreciated, as are resources related to basic networking that would help me here.

2
  • Windows is probably able to serve your device a dhcp address, whereas Ubuntu will not do this by default. When you connect your device to the Windows vm, what address does pull and what is the subnet? You’ll probably have to check on the device to find that info. Aug 5, 2021 at 3:06
  • Also, if you have a spare router lying around, you can put it in between your device and Ubuntu machine and that should also allow you to connect Aug 5, 2021 at 3:09

1 Answer 1

1

Turn DHCP off on your device, and assign the device the address 192.168.2.2 with subnet 255.255.255.0 and gateway 192.168.2.1. Then on your Ubuntu machine, create a new manual connection without dhcp for your Ethernet port, and set the address to 192.168.2.3, with subnet 255.255.255.0 and gateway 192.168.2.1. You should now be able to ping your device from the computer.

Checkout pages 30-33 in this link for more details.

6
  • Thanks for this (and your comments), I'll try this in the morning and get back to you.
    – nivk
    Aug 5, 2021 at 5:19
  • It appears that this method works, thank you. I noticed another section on page 183-184, suggesting that another solution could be simply adding the relevant route to the table. (Possible that this is what Windows is doing automatically when it connects over DHCP.) For me, this would be preferable over configuring manually. Would you have any recommended solutions using this approach?
    – nivk
    Aug 5, 2021 at 22:13
  • Unless I am mistaken, your device is not capable of acting as a DHCP server. If you want a direct ethernet connection between your device and Ubuntu without setting static IPs, you'll have to start a DHCP server on Ubuntu which is arguably more configuration than just setting two static IPs. If you're really against the static IPs, you can attach the device to your router and the router will assign the device an address. Aug 5, 2021 at 22:32
  • Here is a guide on how to setup a DHCP server. Make sure you pick a unique subnet (e.g. 192.168.2.0/24) Aug 5, 2021 at 22:35
  • Got it, thank you for the references/resources as well.
    – nivk
    Aug 5, 2021 at 22:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .