1

I use CentOS 8.4, libvirtd (libvirt) 6.0.0, Vagrant 2.2.18, gem version 2.7.6.3 and ruby 2.5.9p229 (2021-04-05 revision 67939) [x86_64-linux]

I am trying to use vagrant to build VM's on Qemu/KVM. Technically, KVM is running fine and I am manually able to create VM's. It's just that, I am unable to create VM's using vagrant. I installed vagrant and vagrant plugin for libvirt. Version is: vagrant-libvirt (0.5.3, global)

I tried to bring up vagrant using this command vagrant up --provider=libvirt and got error as

/usr/lib64/libk5crypto.so.3: undefined symbol: EVP_KDF_ctrl, version OPENSSL_1_1_1b - /home/user/.vagrant.d/gems/2.7.4/gems/ruby-libvirt-0.7.1/lib/_libvirt.so (LoadError)

I use OpenSSL version as 1.1.1g FIPS 21 Apr 2020

How to fix this issue?

1 Answer 1

0

I don't have a solution, but I'll share additional details here that won't fit in a comment.

I run into the same issue using:

  • AlmaLinux 8.5 (which seems true to the advertised claim of being "bug for bug compatible" with RHEL 8.5 ;))
  • Vagrant 2.2.19
  • I had to run CONFIGURE_ARGS="..." vagrant plugin install vagrant-libvirt, in order to see your error, but afterwards ended up stuck in the same spot.

Seems to be a unresolved bug related to how openssl is bundled per this source: https://bugzilla.redhat.com/show_bug.cgi?id=1925782

This kind of thing usually happens when someone else embeds their own copy of openssl and it doesn't have the same symbols that the system one does. In this case, it looks like your copy of vagrant bundles its own openssl (!):

$ rpm -ql ./vagrant_2.2.14_x86_64.rpm | grep crypto.so /opt/vagrant/embedded/lib64/libcrypto.so /opt/vagrant/embedded/lib64/libcrypto.so.1.1 $

This is an external package; we didn't provide it. We did provide a system openssl (we think it's pretty good), and the package should be using that, not embedding its own thing. In particular, it needs to not be overriding the system libraries with its own when it calls out to other system functionality, like that using krb5.

Seems to be an unresolved issue that's been going on for a while as there's multiple issue tickets on it. https://github.com/vagrant-libvirt/vagrant-libvirt/issues/1088#issuecomment-686513145

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .