0

I'd like to add to the default configuration file that comes with ptp4l. I've tried adding multiple configs, all of which are described in the manpage, but regardless of what configuration I add, I get:

unknown option [option] at line x in global section

A MWE of this is to add

BMCA        noop

at the bottom of the default config, and ptp4l throws an error on startup.

Here is a section of my config file:

#
# Clock description
#
productDescription      ;;
revisionData            ;;
manufacturerIdentity    00:00:00
userDescription         ;
timeSource              0xA0
#
# Program and Clock options
#
BMCA                    noop
slaveOnly               1

Am I somehow writing the configs wrong? I'm on a Ubuntu VM, but I'm editing with VI so I can't imagine there are any formatting errors.

1 Answer 1

1

I encounter the same issue and update linuxptp version is the solution.
May be you should update your linuxptp to the newest version.
Don't install by apt-get as it provide version 1.8 (up to now) which do not support BMCA option, download the newest version source and compile install instead.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .