0

i am trying to install kubernetes and docker on Centos 8 but i have package conflicts how do i fix them?

[root@master-node ~]# yum install kubeadm docker -y
Ultima verifica della scadenza dei metadati: 3:22:18 fa il mar 27 lug 2021 18:20:38 EDT.
Package kubeadm-1.21.3-0.x86_64 is already installed.
Errore:
 Problema: problem with installed package docker-ce-cli-1:20.10.7-3.el8.x86_64
  - package docker-ce-cli-1:20.10.7-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:19.03.13-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:19.03.14-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:19.03.15-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:20.10.0-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:20.10.1-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:20.10.2-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:20.10.3-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:20.10.4-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:20.10.5-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - package docker-ce-cli-1:20.10.6-3.el8.x86_64 conflicts with docker provided by podman-docker-3.1.0-0.13.module_el8.5.0+733+9bb5dffa.noarch
  - conflicting requests
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

[root@master-node ~]# yum install kubeadm docker
Ultima verifica della scadenza dei metadati: 1:50:16 fa il mer 28 lug 2021 02:08:47 EDT.
Errore:
 Problema: problem with installed package docker-ce-cli-1:20.10.7-3.el8.x86_64
  - package docker-ce-cli-1:20.10.7-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:19.03.13-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:19.03.14-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:19.03.15-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:20.10.0-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:20.10.1-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:20.10.2-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:20.10.3-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:20.10.4-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:20.10.5-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - package docker-ce-cli-1:20.10.6-3.el8.x86_64 conflicts with docker provided by podman-docker-3.3.0-0.15.module_el8.5.0+870+f792de72.noarch
  - cannot install the best candidate for the job
(try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)

1 Answer 1

0
# yum install kubeadm docker 

-> install podman-docker from Red Hat

# yum install kubeadm docker-ce.x86_64 

-> install docker-ce. But you need the docker-ce repo in place.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .