2

I want to install the proprietary Nvidia driver. Downloaded it from here. I have the 64-bit one.

However, when I try to install it, I can't because the Nouveau driver is already there. I have spend hours trying just about everything I could find to disable Nouveau, but I still can't manage to disable it.

Does anybody know how to disable Nouveau in Fedora 18?

EDIT: Ok I should have said this ago but I didn't want to bump the post so I didn't, I discovered that it's impossible to install the nvidia drivers on my computer since my computer (a MacBook) uses EFI which isn't supported by the drivers. BIOS emulation sucks so it's not possible. Sorry I didn't say this earlier and thanks everyone for trying to help me.

3
  • The nVidia driver is (quite rightly) disparaged for instability and general flakyness. It doesn't track upstream changes (which show up first in Fedora) well.
    – vonbrand
    Commented Feb 25, 2013 at 20:35
  • 1
    @vonbrand But with Nouveau I have overheating issues, GPU lockups and weird random graphical things around my menu's (Or is that not caused by Nouveau?). Also I want to play 3D games and stuff and I heard Nouveau is horrible at rendering 3D games. - I am looking into Kubuntu now and see if that works good. BTW thanks for trying to help
    – jobukkit
    Commented Feb 25, 2013 at 20:40
  • I switched to Kubuntu now, but I will make a Fedora install again to try the answers out. Can be useful for other people in the future, and for me if I would switch to Fedora again.
    – jobukkit
    Commented Feb 26, 2013 at 21:50

5 Answers 5

1

Try installing the Nvidia drivers from RPMFusion. It takes care of disabling Nouveau for you, and you get automatic updates since it uses yum.

6
  • Sadly it does not "disabling Nouveau for you" well enough, otherwise I wouldn't be looking for an answer to the same question.
    – hidralisk
    Commented Feb 26, 2013 at 5:44
  • 1
    com. BOY did not mention trying the one from rpmfusion, maybe it's enough for his needs? It certainly was for mine when I set up a fedora 18 machine two weeks ago.
    – Wieland
    Commented Feb 26, 2013 at 8:59
  • Gave me this error: No package akmod-nvidia availible Error: nothing to do
    – jobukkit
    Commented Feb 26, 2013 at 14:32
  • 1
    Did you enable the RPMFusion repositories first?
    – Wieland
    Commented Feb 26, 2013 at 19:57
  • Ok I enabled the RPMFusion repo's now and installed the drivers, but now when I turn on my computer, it freezes after the Fedora logo appears. What to do?
    – jobukkit
    Commented Feb 27, 2013 at 16:44
1

If not true then false has a guide to installing the NVidia driver on Fedora 18. I suggest you follow that. It appears (form the comments) that you do not need to manually uninstall Noveau but if you do this is what you should use:

mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img
dracut /boot/initramfs-$(uname -r).img $(uname -r)
1

To remove / disable nouveau drivers from kernel initramfs (courtesy: If-Not-True-Then-False):

## Backup old initramfs nouveau image ##
mv /boot/initramfs-$(uname -r).img /boot/initramfs-$(uname -r)-nouveau.img

## Create new initramfs image ##
dracut /boot/initramfs-$(uname -r).img $(uname -r)

##Reboot
init 6

To blacklist the nouveau drivers:

Make changes in the /etc/default/grub as follows:

GRUB_CMDLINE_LINUX="rd.md=0 rd.lvm=0 rd.dm=0 SYSFONT=True  KEYTABLE=us rd.luks=0 LANG=en_US.UTF-8 rhgb quiet rdblacklist=nouveau"

then, update the grub2 config file as follows:

grub2-mkconfig -o /boot/grub2/grub.cfg
0

My ati card is currently sitting in a box because I don't need it (or to waste wattage) but the last time I used it with linux ~4 years ago to do some openGL work, there was a very very substantial difference between the prop driver and the open source one, so you are probably not unjustified here. I did have access to an NVIDIA card at the time and the issue was much the same for that. A recent nouveau benchmark using ubuntu 12.10 seems to indicate nouveau still lags considerably behind the prop driver.

So, I know you are frustrated BUT you would be better off putting more effort into the question -- saying, "I have spend hours trying just about everything I could find" without saying what you've tried will put people off, because they won't bother to suggest something that you've probably already tried.

Anyway:

yum list installed | grep ouveau

I left off the [Nn] for simplicity. This will give you a pretty straightforward list. yum remove [package] all of those then try installing. You will need to reboot afterward, but do the install first since you won't have a working GUI otherwise (before rebooting, the driver will still be in memory even though it is no longer on disk).

2
  • Didn't work :-(
    – jobukkit
    Commented Feb 26, 2013 at 7:11
  • @com.BOY : "Didn't work" -- read what I said in the 2nd paragraph again about the value of more explicitly explaining yourself. Keep in mind that oodles of regular users do install the nvidia driver on both fedora and ubuntu, so it is not impossible. You just have to figure out how, and if part of that effort is asking other people for feedback, there are more and less effective ways of doing that ;)
    – goldilocks
    Commented Feb 26, 2013 at 8:27
0

You could blacklist the nouveau drivers.

2
  • Explain how to do that, OP clearly doesn't know.
    – vonbrand
    Commented Mar 25, 2013 at 20:48
  • I have already tried that.
    – jobukkit
    Commented Mar 30, 2013 at 9:38

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .