1

I am on a Thinkpad 460S. There is a media key on the keyboard to cut the wifi via Rfkill (F8).

NetworkManager is grabbing the key and everytime it is pressed, disable or reenable the rfkill switch.

I dont want this to happen and I'd rather use this key in xbindkeys (not usable atm since it is grabbed by NetworkManager).

Is there a way to stop NetworkManager from doing that?

4
  • 1
    I think it's your desktop environment doing that. NetworkManager itself doesn't access the GUI. What desktop environment are you using? Jul 28 at 15:50
  • I'm using i3 so I dont think it would do that? Furthermore I see a networkmanager event in journalctl when I press the button Edit: Checked in my i3 config, I dont find any bindsym that would do this... Jul 28 at 19:56
  • After further investigation, these days, systemd is the one that handles rfkill. And as you found out, that's routed from the kernel. Jul 28 at 20:50
  • Would disabling systemd-rfkill.service and systemd-rfkill.socket be enough? I tried and it doesnt seem to work. Would you have a solution? Jul 28 at 20:52
1

It seems that this is a (deprecated) kernel feature. This post gives a solution:

rfkill: input handler disabled

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.