1

I was able to successfully join my Ubuntu 18.04 machine into AD.

For this I'm using SSSD and Kerberos.

I can ssh into in using AD domain credentials. Everything is fine except that those domain users are not persistent.

When a domain user enters a Windows machine, then a home directory is created automatically and the user is added into the users list. This allows the domain user to log into Windows even if there's no network connection.

But on my Ubuntu machine no home directory is created and no users are added into /etc/shadow and /etc/passwd. It means that if AD was down or the network was down, then there's no way for the domain users to login.

Where can I find information on how to configure this properly? What files I need to look into? Or maybe Linux's AD stack does not allow it?

1 Answer 1

1

To enable creation of users home directories exec this command (as root):

pam-auth-update --enable mkhomedir

About not available AD - sssd support cache so for some time you will be able to login with cached credentials. In domain section of sssd.conf you can add something like to manage the time:

cache_credentials = true
account_cache_expiration = 7
entry_cache_timeout = 14400

(default time for cache is 5400 seconds)

And AFAIK sssd never create entries in /etc/passwd and /etc/shadow

1
  • 2
    Thank you a lot. I saw cache_credentials = true, but wasn't sure what it meant exactly. And pam-auth-update --enable mkhomedir worked perfectly, but only for Ubbuntu. For my Debian machine I had to manually add session required pam_mkhomedir.so umask=0022 skel=/etc/skel into /etc/pam.d/common-session Jul 28, 2021 at 8:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .