3

After upgrading to Ubuntu 21.04 my computer displays the following error on resume from suspend: Bluetooth: hci0: Reading supported features failed (-16)

The computer does not respond after this is printed and I have to reboot it to get it working.

Other than that, Bluetooth is working normally. This issue prevents me from using suspend since the computer has to be rebooted after it attempts to wake up and stops responding.

The PC has the ID 8087:0a2b Intel Corp. Bluetooth wireless interface

2

4 Answers 4

1

After searching a bit, it seems that "everyone" who had that error, got it solved by running sudo systemctl restart bluetooth. After running the command and rebooting your computer does it get solved?

1
  • 2
    I have to restart the whole PC each time it tries to resume from sleep, so this does not help
    – Sergey
    Jul 29, 2021 at 6:12
1

A workaround discovered by lfreist on Stack Overflow:  When you see the "Bluetooth: hci0: Reading...", do Ctrl+Alt+F2 to reach tty2 and then press Ctrl+Alt+F1 to make it to the main login screen.  It's not a solution but will unblock you from using your Linux.  I have wasted countless hours with no solution.

https://stackoverflow.com/a/71983685/12059401

0

Upgrading to Ubuntu 21.10 solved the issue.

0

I have been seeing this occasionally on various Debian based builds. I have a kind-of workaround that helps me out.

If your version of Ubuntu has "Hybrid Sleep" functionality, try it. It basically suspends/and writes the RAM to disk like a hibernation, in the event that the computer loses AC power during the suspend. When I resume, my devices are already paired and the audio profile (which is what I mainly use BT for) is the same as prior to suspend.

This is not a resolution to the issue, but an easy way to circumvent without making any major changes or upgrades if un-necessary

The only "adverse" affect is it takes a few moments more to complete the suspend operation. Hope this helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .