0

Fresh install of Fedora 34. Home software updater is packagekit behind, though gnome-packagekit says gnome-software and all comoonents like fwupd are not installed on the machine, dnf says the same.

Gnome-software installs stuff, however it does not uninstall some default apps, it says could not remove, package missing, although the packages successfully runs. It removes Flatpaks normally though. The interesting thing is that dnf and packagekit also say that such package is not installed. To remove it for real on the system, I need fo install it eith dnf or packagekit but not gnome-software, because there it exists and it actually works prior to installing it, after that I sill remove it by dnf kr packagekit (again gnome-softsare does not remove them) , only then gnome software will have launch button removed and inly an uninstall button with red left, which again does not work, bur upon reboot the package is gone succesfully from the store.

I tried refreshing and uodating and cleaning caches on both dnf and packagekit, I also tried btrfs rollbacks, to no avail. Additionally, I think I had packages saying that are inztalled through dnf, but not actually as the bins were missing, this could have been fixed with dnf history rollback, which I am not sure if should be the case.

1 Answer 1

0

Did you update the RMP repository? if not try this.

sudo rpm -Uvh http://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm

sudo rpm -Uvh http://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

If you want to remove the packages 📦 try…

Sudo def remove Eg:> sudo dnf remove vlc-1:3.0.16-1.fc34.x86_64

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .