At present I have pulseaudio configured with the jack sink and source modules:

load-module module-jack-sink 
load-module module-jack-source

I've recently discovered that the first capture input on my audio capture card is a little faulty, which has caused me to move to the second capture.

Although this is problem is likely very uncommon, Discord seems to have problems with this arrangement. At present when in a VC normally, there's no issue. However when watching someone's stream, I'm unable to be heard.

After opening QjackCtl, and navigating to the connection graph, I could see that capture_1 is mapped to front-left, and capture_2 is mapped to front-right. I can manually connect capture_2 to front-left, which solves my discord issue, but I'm wondering if there is a way to have this persist, since a pulseaudio -k would revert it back to the default connections.

What would I need to configure, in order to have capture_2 mapped to both front-left and front-right on pulseaudio startup?

  • 1
    See if load-module module-jack-source channel_map=front-left,front-left does what you need
    – Tom Yan
    Jul 27, 2021 at 7:06
  • I've just tested that, but seems that the source is no longer available when viewed from the QjackCtl graph. I did try swapping the mappings, using what you used as an example, load-module module-jack-source channel_map=front-right,front-left which does resolve the mapping. Obviously, it be nice to be able to map both inputs to both sources, but I'll at least be able to work with this, thank you.
    – humroben
    Jul 27, 2021 at 8:23

1 Answer 1

  1. Add an option to module-jack-source to prevent default connections
    load-module module-jack-source connect=no
  1. use these 2 commands to connect capture_2 to both channels of Pulseaudio JACK source
    jack_connect system:capture_2 Pulseaudio\ Jack\ Source:front-left
    jack_connect system:capture_2 Pulseaudio\ Jack\ Source:front-right

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .