This is the first time trying to install Debian (10.10) on this system (including proprietary drivers). Install worked without (apparent) errors, but I am unable to get into the desktop.

After booting up I get to a black screen with a pointer. The pointer moves, and it seems to go past the monitor on the left. No menus or icons available to log in and access the desktop. I am able to boot into recovery and access a command line. Sometimes I get a blue screen saver.

The system is an old dell laptop (Inspiron N5010). The screen has been removed and I am using an external monitor. Maybe that is the source of the issue, perhaps related to GNOME or Xorg? System was working on the previous Windows 7 install. Any pointers on how to further investigate are appreciated. I am somewhat competent at navigating/using Linux, but not much experience installing/administering it. Let me know of any info/logs that would be useful.


These were grabbed in recovery mode:

lspci, dmesg

Added (not from recovery mode):

Xorg.0.log, dmesg

Toward the end of Xorg.0.log I see this:

[ 52739.928] (EE) dbus-core: error connecting to system bus: org.freedesktop.DBus.Error.FileNotFound (Failed to connect to socket /var/run/dbus/system_bus_socket: No such file or directory)

Followed by various devices being removed and the server being terminated.

  • Have you tried Ctrl-Alt-F1 (or 2, 3, etc) to get a console login (without recovery mode) ? You'd want to look potentially into several files in /var/log; syslog for example or any log containing "X" or "X11" is where I would start. Post anything that seems suspicious/relevant. Jul 24, 2021 at 22:57
  • I can access a console with Ctrl-Alt-F2, /var/log/Xorg.0.log does look a little suspicious toward the end. I've added that to my post. Jul 26, 2021 at 21:37

1 Answer 1



Useful, Describes the errors to a Tee. The second log points to the exact same problem.

[ 3811.102369] sd 6:0:0:0: [sdb] Attached SCSI removable disk
[ 3832.749534] FAT-fs (sdb1): Invalid FSINFO signature: 0x429058eb, 0x00000000 (sector = 1)
[ 3832.758491] FAT-fs (sdb1): Volume was not properly unmounted. Some data may be corrupt. Please run fsck.
[ 3896.176938] FAT-fs (sdb1): Invalid FSINFO signature: 0x429058eb, 0x00000000 (sector = 1)
  • Based on the device name (sdb1) and the removable disk message, I think those messages might refer to a thumb drive that I may have had plugged in during boot up. I haven't seen the error messages referenced in your link like: Welcome to GRUB! Error: unknown filesystem. Entering rescue mode… grub rescue> Jul 26, 2021 at 21:51
  • Took another dmesg and couldn't find those FSINFO signature or Volume not properly unmounted messages. Jul 26, 2021 at 22:37
  • Good advice.. I was just concentrating on the FSINFO errors :)
    – Shanzem
    Jul 27, 2021 at 16:42

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .