1

I am currently facing troubles in installing google chrome/chromium in Amazon EC2 instance.

I tried the command,

[ec2-user@ip-XXXX yum.repos.d]$ sudo yum install google-chrome-stable
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
amzn2-core                                                                                                                                                                                  | 3.7 kB  00:00:00     
http://dl.google.com/linux/chrome/rpm/stable/aarch64/repodata/repomd.xml: [Errno 14] HTTP Error 404 - Not Found
Trying other mirror.
191 packages excluded due to repository priority protections

I have seen any solutions from stack overflow/other sites for this, but I nothing works and getting the same error. Some of them I tried are,

  1. https://stackoverflow.com/questions/21623131/centos-unable-to-install-chromium-browser
  2. How to install Google Chrome on CentOS, Red Hat or Fedora
  3. Unable to install Google Chrome on Linux

It looks like the repository is not found. It is true, as I get the same when I tried to access the link from the browser. As an alternative, I tried downloading the rpm and insatlled, but it seems to be a wrong architecture (but I thought its the same),

[ec2-user@ip-XXXX yum.repos.d]$ sudo wget https://dl.google.com/linux/direct/google-chrome-stable_current_x86_64.rpm
......
[ec2-user@ip-XXXX yum.repos.d]$ sudo yum install google-chrome-stable_current_x86_64.rpm
Loaded plugins: extras_suggestions, langpacks, priorities, update-motd
Examining google-chrome-stable_current_x86_64.rpm: google-chrome-stable-92.0.4515.107-1.x86_64
Cannot add package google-chrome-stable_current_x86_64.rpm to transaction. Not a compatible architecture: x86_64
Error: Nothing to do

Other information about the OS and repo are,

/etc/yum.repos.d/google-chrome.repo

[google-chrome]
name=google-chrome
baseurl=http://dl.google.com/linux/chrome/rpm/stable/$basearch
enabled=1
gpgcheck=1
gpgkey=https://dl-ssl.google.com/linux/linux_signing_key.pub

Os details

[ec2-user@XXXX yum.repos.d]$ uname -m
aarch64
ec2-user@XXXX yum.repos.d]$ cat /etc/os-release
NAME="Amazon Linux"
VERSION="2"
ID="amzn"
ID_LIKE="centos rhel fedora"
VERSION_ID="2"
PRETTY_NAME="Amazon Linux 2"
ANSI_COLOR="0;33"
CPE_NAME="cpe:2.3:o:amazon:amazon_linux:2"
HOME_URL="https://amazonlinux.com/"
[ec2-user@XXXX yum.repos.d]$ rpm -E %{rhel}
7

Could someone please help on this?

1
  • The (centos) command is yum install chromium ..... Please always do a search, e.g. yum search chrom Jul 24 at 12:44
1

You are on an ARM64 (aarch64) system, Google doesn't provide repository for this architecture so you can't install Chrome from it. The RPM package you downloaded manually is for x86_64, you can't install it on ARM64, the error clearly says it:

Cannot add package google-chrome-stable_current_x86_64.rpm to transaction. Not a compatible architecture: x86_64

One option would be to use Chromium, which is available in the EPEL repository, unfortunately EPEL 7 is also not available for aarch64 so you'll unfortunately need to build it yourself from source.

(I've updated my answer, the previous version was based on assumption that Amazon Linux is based on RHEL/CentOS 8 which has aarch64 EPEL, but as it seems to be based on RHEL/CentOS 7 which doesn't have aarch64 EPEL so using EPEL is not possible.)

2
  • Thank you @Vojtech Trefny. I tried the same and it mentions No package chromium available.. I used epel-release-latest-7.noarch.rpm because I got an error Requires: redhat-release >= 8
    – Praveen
    Jul 24 at 18:11
  • I've updated the answer, I thought Amazon Linux is based on RHEL 8, but it is based on RHEL 7 and EPEL 7 doesn't have aarch64 version so your only possibility seems to be building Chromium from source. Jul 24 at 19:00

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.