7

This is a variant of this question. But the provided answers either don't seem to work or would entail not being able to have Zoom (cf below).

Situation:

  • I run Kubuntu 21.04 with KDE Plasma 5.21.4
  • Zoom requires IBus. I have Zoom and I need it.
  • IBus has by default an icon on the system tray in addition to the default keyboard selector
    Two keyboard selectors in systray

How can I get rid of the IBus keyboard selector (the ugly leftmost one) in the system tray ?

What I have tried:

  • Uninstalling IBus means uninstalling Zoom ; not an option
  • Start-up script to kill IBus (ibus exit) => no sys tray icon but keyboard doesn't work in certain apps
  • Uncheck "Show icon in sys tray" in IBus Preferences => IBus still appears in system tray even after reboot even though box remains unchecked
  • Do the same with dconf from the command line => IBus still ignores the config option
  • Start-up script to restart IBus without panel (ibus-daemon -rd --panel=disable) => no sys tray icon and IBus is running (ibus-daemon says something about an existing instance) but the dead keys of my French keyboard ("circumflex + e" displays "e" instead of "ê") don't work anymore.
  • Tried to hide the IBus sys tray icon in the System Tray Configuration Menu but the drop-down for display options is grayed out:
    "Always shown" cannot be changed for IBus Panel
3
  • 1
    I had the same issue, found your post and managed to hide the icon from System Tray Settings. The selection wasn't grayed out in my case. I'm running Kubuntu 21.10 (Plasma 5.22.5)
    – Expurple
    Dec 27, 2021 at 23:48
  • For me, re-checking then un-checking the show icon preference was enough to get it to disappear again (for now).
    – Walf
    Feb 7, 2022 at 0:46
  • Thanks! Mysteriously, unchecking and rechecking multiple times does not do anything for me...
    – Ahmad B
    Feb 10, 2022 at 8:30

4 Answers 4

8

You can exclude ibus from zoom's dependencies with the following script:

#!/bin/sh
set -xe

tmp=$(mktemp -d)
cd "${tmp}"

name='zoom.deb'

wget https://zoom.us/client/latest/zoom_amd64.deb -O "${name}"
dpkg -x "${name}" zoom
dpkg -e "${name}" zoom/DEBIAN

sed -i -E 's/(ibus, |, ibus)//' zoom/DEBIAN/control

dpkg -b zoom "${name}"
sudo dpkg -i "${name}"

rm -rf "${tmp}"

Alternatively, you can follow this advice

Right-click on the IBus panel icon: Preferences: Advanced: Keyboard Layout: Use system keyboard layout.

After that I set the IBus Panel icon to "Always hidden" in Plasma system tray settings".

UPDATE: Another option (I ended up with personally) is to create a dummy package which will replace the real packages. After installing that package, all apps depending on the unwanted packages like ibus would remain upgradable, so you won't need to do anything after that.

To create that package, equivs-build tool from equivs package can be used.

Create a text file, let's say blacklist-deb-packages and fill it with the following content. List the packages you want to not install in Provides section:

Section: misc
Priority: optional
Standards-Version: 3.9.2

Package: blacklist-deb-packages
Provides: ibus, ibus-table-emoji, nautilus, qtbase-abi-5-15-3, libappindicator3-1
Description: dummy package to prevent the installation of unwanted packages

After creating the file, run the following in that file's directory:

equivs-build blacklist-deb-packages && \
sudo dpkg -i ./blacklist-deb-packages_1.0_all.deb
2
  • Thanks! Although your proposal is interesting, I validated the other answer because it looked less invasive to me. The "alternatively, ..." advice you provide might be useful to some but doesn't apply to my situation because, as I detailed in the question, the "Always Hidden" option is not available to me (for unknown reason).
    – Ahmad B
    Oct 31, 2022 at 15:23
  • 1
    @AhmadB I've updated the answer with another, less invasive option
    – Grief
    Nov 1, 2022 at 18:41
2

If you need Zoom and don't want to repackage zoom.deb, one option is to let IBus be installed, but disable it at the user level (so that the default input manager is used) by having the line

run_im none

in the file .xinputrc.


Edit: To fully get rid of ibus I ended up using the script from Grief's answer to repackage zoom's deb.

1

Best option I found so far: ibus-dummy --

available directly by apt install ...
This will provide a dummy/fake ibus package for whatever tools that insist needing it.
If somehow you need the real ibus package, then just uninstall this one and install ibus instead.

-1

In my case, after KDE Neon upgrade to Jammy,IBUS starting appears in tray, and its tray preferences do not work. (It was installed by Zoom).

So, I uninstall Zoom and IBUS, and reinstall again, but from SNAP or FLATPAK repositories, the package comes with all the libs and requeriments.

in my case the problem was solve that way good luck!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .