1

I am trying to package my application in appimage format. I'm using appimage-builder to do so, and using Ubuntu 18.04, as appimage-builder documentation recommends. But I am unable to do so. I cloned my repository, and I ran meson build -Dprefix=/usr, then DESTDIR=$PWD/AppDir ninja -C build install then appimage-builder --generate, this did not add any dependency at all in the recipe, so I added them manually, then I run appimage-builder. My asset files fails to load using this method when testing on the machine the appimage is being generated on. As I am generating a config.h based on the prefix the user passes to meson and using those paths inside application to find asset files like icons and all. When the generation completes, all tests pass, while failing to load assets, which does not cause application to stop just gives a warning. But outside of this machine I cannot run this appimage anywhere, I get this error when running on a different machine,

**
Gtk:ERROR:../../../../gtk/gtkiconhelper.c:494:ensure_surface_for_gicon: assertion failed (error
== NULL): Failed to load /org/gtk/libgtk/icons/16x16/status/image-missing.png: Unrecognized image file format (gdk-pixbuf-error-quark, 3)
[appimage-binfmt-bypass/bin] ERROR: child exited with code 6

Here is a link to my project - SampleHive

If needed I can also share the generated recipe, including the things a I added manually.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.