I have several applications installed that handles url schema rdp:// (for example, rdp://[email protected]). These applications are Krdc and Remmina. I want such links to be opened in krdc, but they are opened in remmina. I do not want to uninstall remmina. But when I uninstall it, then krdc is opening such links.

In kde settings under Applications there are Default Applications, but unfortunately it only contains several types of them (web browser, file browser, mailer, terminal).

Also, under applications there is File Associations. If I search "rdp" there, I only see related application/x-remmina, but there is no krdc.

How do I set krdc as a handler for rdp:// protocol in kde settings?

1 Answer 1


I do not know if that is on purpose, but in kde settings I cannot see the mime types for them. I mean, I can add a new one, but initially there is no one. However, applications are apparently somehow sorted.

I have found this question, that helped to achieve what I want.

First, in /usr/share/applications find the .desktop file for krdc and see for MimeType line. You see that the mime type is x-scheme-handler/rdp. Now we can query the sorter.

When krdc installed alone:

$ xdg-mime query default x-scheme-handler/rdp

When remmina installed in parallel with krdc:

$ xdg-mime query default x-scheme-handler/rdp

Take that name of .desktop file for the next command. After I run

$ xdg-mime default org.kde.krdc.desktop x-scheme-handler/rdp

I can query again and see that it is now krdc. Now when I click rdp:// links, they are opened in krdc.

P.S. Despite I achieved the task, I am still interested the "gui" way and why there is no initially x-scheme-handler in File Associations. Comments are welcome.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .