0

Linux Mint was running fine until one day, suddenly I was unable to write any changes to other file systems. Screenshots from (1)Sublime Text (2)VS Code: https://i.stack.imgur.com/H0VYi.jpg

The first thing I tried to do was check if permission to read and write was revoked, which seemed to be the only possible reason for this error, but to my surprise it had read and write access and group was set to root.

Permissions for the folder

Then I opened Thunar with root access and tried changing Group to juvenile_lad (user) but then I receive the following error enter image description here

Now if I click Yes, then it keeps on prompting me for every single file inside the folder, which basically means no changes were made. Then I tried following an answer given in the following post: https://askubuntu.com/questions/628862/sublime-text-3-authentication-question-when-saving-document# , but still had the same error just in the terminal.

At this point, I have no idea what or where to change permissions from. It was working perfectly a day before and I don't remember making any changes to the system settings whatsoever.

4
  • This is not a problem with permissions, you are on the wrong track. Your entire filesystem is read only. Check the output of mount for ro. To fix this, run fsck (which should happen automatically on reboot).
    – Panki
    Jul 20, 2021 at 14:25
  • 2
    No! Don't run fsck on a mounted filesystem Jul 20, 2021 at 14:55
  • If a file is owned by root then (unless you are root) you can't change its permissions even when it is mounted rw. BTW as a Mint user is there any reason why you are not using nemo? Jul 20, 2021 at 17:36
  • Thunar works just fine for me. Jul 21, 2021 at 15:07

2 Answers 2

1

Following @Panki's advice

This is not a problem with permissions, you are on the wrong track. Your entire filesystem is read only.

I found out that I was really on the wrong track, However, The solution to this problem turned out to be a lot more simple than I thought.

Took a different approach and came to know that Windows 10 (on dual-boot) can enable Fast Startup on its own & all I had to do was to disable Fast Startup in the Settings>Power Options and that fixed the problem.

Here the steps:

  • press the Windows Key + R to bring up the Run dialog, type powercfg.cpl and hit Enter. The Power Options window should appear. Click "Choose what the power buttons do" from the column on the left.
  • Scroll down to "Shutdown settings" and uncheck the box for "Turn on fast startup".

Note: If these options are greyed out then you may need to click "Change settings that are currently unavailable".

0

So, as the error message says, the file system is mounted read-only.

Seeing the path is /mnt/longnumber/something, I bet this is an external drive, so you can boot your system without it. That's great. Because the most likely reason is that this file system is inconsistent, and Linux decided to make it read-only, so that you don't overwrite anything accidentally. Things are broken at this point, and you need to fix them.

  1. We're read-only. That means we can't do any damage. Backup the files you care about, that means copying them off the disk. If you encounter files that can't be read, yes, you've got a damaged file system. With a bit of luck they can be safed, but for now they're inaccessible.
    The following steps are usually safe, but there's no guarantee we're not making things worse. Note down the device name: /dev/something; you can check it using df -h /mnt/longnumer/.
  2. Unmount the damaged file system sudo umount /mnt/longnumber. Make sure that worked;
  3. check that file system using the appropriate file system checker. These long numbers are often names of Windows partitions. If this is an NTFS partition, I strongly recommend you check it with a Windows machine. Else, sudo fsck /dev/something should do the trick and ask you to confirm things.
  4. Make sure another run of fsck tells you the file system is clean.
  5. sudo mount /dev/something /mnt/longnumber; watch for error messages printed to dmesg or on the console.

general remark: The file is called "/Team Something/2 - Code /ABC Backup/V2/index.html". This indicates you really need to learn about version control! And I mean need: You're working on a team, you've got code, you've got versioning!

Learn how to use git, e.g. with bitbucket.org or github.com ; it's really not hard, and it will, I promise, be worth it in less than 2 days of teamwork. I've worked with student teams that didn't know git before, and I'll never regret them spending the hour on getting started with git.

1
  • thanks for the effort but as you can see all I had to do was disable quick boot in BIOS settings. That worked perfectly. Now onto version control, I've the project up on github and I push all changes I make but tbh I also feel like I need to spend some time on version control because I usually have a ton of folders after a project is complete. Thanks for the advice. Jul 21, 2021 at 3:35

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .