4

I have added a second keyboard language layout (Persian) in Linux Mint 20.2 Cinnamon and in the keyboard setting I've set it to use shortcut win+space to change the layout.

It works fine when the selected layout is the primary (US English) and the shortcut changes the layout to secondary layout (Persian) but when I want to change from (Persian) to (English) it doesn't work and I have to use mouse and change it from the panel icon.

I've changed the shortcut to alt+shift but the problem still remains.

2
  • That's weird! I have the same problem with Linux Mint 20.2 Mate when I use win + space. But now I added alt + shift and it works fine.
    – AMK
    Commented Dec 18, 2021 at 8:23
  • Does this help? askubuntu.com/a/1134384/85695
    – terdon
    Commented Jul 2, 2022 at 14:41

3 Answers 3

2

My solution which solved this issue in Linux Mint 20.3:

  1. Open Keyboard Preferences:

    Linux Mint Menu > Control Center > under category Hardware : keyboard

  2. Tab Layouts > Reset to Defaults

  3. Add your Layout :

    • Tab Layouts > Add
    • By Language : Persian
    • Variants : Persian
    • Add
  4. Change the shortcut to Alt + Shift :

    Tab Layouts > Options > Switching to another layout > Alt + Shift

0

In Linux Mint 21.1 Cinnamon, I went through this steps and my issue fixed:

  1. Open Keyboard Settings
  2. Choose Layouts
  3. On right bottom corner, open Options...
  4. Click on Switching to another layout
  5. Select Alt+Ctrl or Alt+Shift (you can select both)

Attention always press Alt first and press Ctrl or Shift second

-1

Looks like I found that it could be done with:

CapsLock + Shift

You could check:

Menu > Keyboard > Layouts > Options

For your custom shortcut. Or Reset to Defaults and the above combination should work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .