I'm trying to boot GParted live 0.14.1-6 within Oracle Virtualbox 4.2.6 r82870 (Extension Pack installed).

The host OS is Windows 7, the physical graphic card is an AMD Radeon HD 6900. The physical CPU is an AMD Phenom II X6 1100T.

I created a VM in order to test the latest ArchLinux release in Virtualbox with the following settings:

  • 1024 MB RAM
  • 8 GB Disk (VDI)
  • EFI enabled
  • Video Memory: 128 MB
  • Monitor count: 1

I chose my GParted iso (gparted-live-0.14.1-6-amd64.iso) with the "Add virtual CD/DVD disk file" feature (attached to the virtual IDE controller).

Gparted live CD/iso boot correctly, I select the default option "GParted live default settings" in the GRUB menu (GRUB 1.99-23.1), set the keyboard layout and preferred language. When it comes to the video mode choice, I tried all the following options:

  1. Continue to start X to use GParted automatically
  2. Run 'Force video' to config X manually: I tried this option with 1024x768 & 800x600 resolution, either with default vesa driver and ATI (24 bit color depth).

All those choices lead to the same error, GParted gets stuck at this point:

Fatal server error:
no screens found

server terminated with error (1).
xinit: giving up
xinit: unable to connect to X server: Connection refused
xinit: server error
  • I tried the different tips provided by the GParted Live documentation regarding booting without success. I disabled the "Enable EFI" setting for my VM in Virtualbox, than GParted boot normally and the graphical environment seems to works properly.
    – g0lem
    Mar 14 '13 at 20:36
  • 2
    I followed the opposite of g0lem's advice and enabled EFI for my VM and it started working. Jun 5 '15 at 14:11
  • @Shapeshifter: I can confirm the same thing - seems that in the past disabling EFI was correct, maybe now enabling it is the right fix. Mac host, VirtualBox 4.3.26 and GParted Live image gparted-live-0.22.0-2-i586.iso Jun 5 '15 at 16:25

I enabled EFI for my VM while using gparted-live-0.22.0-2-i586 and it started working. I also noticed that the disk needed to be added to a SATA controller. It appears that older versions of gParted required EFI to be disabled.

  • I also enabled EFI and added an new disk image to the SATA controller and it worked. Don't know which f the measures is necessary
    – yunzen
    Jun 15 '15 at 10:23
  • 2
    Don't forget to turn EFI back off when you are done. In my case Ubuntu wouldn't load until I had disabled EFI after finishing with gparted.
    – Peter
    Jul 29 '15 at 20:40
  • 2
    Worked a treat for me. The startup looked better, and the default options took me straight into the gparted GUI.
    – cs94njw
    Jan 28 '16 at 16:16
  • Thanks, +1 - this worked on Windows 10 running on a Thinkpad W530
    – WoJ
    Apr 23 '16 at 8:33

Please go to oracle virtual box and follow the following steps

  1. create a new virtual box as Gparted.
  2. go to settings and set the primary controller as Gparted ISO.
  3. Secondary control should go to the vdi which you need to exted.
  4. stat the Gparted virtual box
  5. Go with default setting
  6. choose startx to start the Gparted.
  7. Then do the disk management.
  • 2
    This question was resolved more than three years ago, and this answer does not seem to address the problem.
    – Law29
    Jul 1 '16 at 9:16

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.