1

Update: I'm happy to report @dartonw 's answer worked and I went and did a checkout and then buildworld and it built successfully in about 6 hours.


So I've been having some issues with jails in freebsd. I run FreeBSD9.1 64 bit on EC2 as a small instance. I recently tried :

cd /usr/src;make buildworld

And after nine hours of compiling it gives me :

{standard input}:12044: Warning: end of file not at end of a line; newline inserted
{standard input}:12142: Error: invalid character '_' in mnemonic
c++: Internal error: Killed: 9 (program cc1plus)
Please submit a full bug report.
See <URL:http://gcc.gnu.org/bugs.html> for instructions.
*** [TransAutoreleasePool.o] Error code 1
Stop in /usr/src/lib/clang/libclangarcmigrate.
*** [all] Error code 1
Stop in /usr/src/lib/clang.
*** [all] Error code 1
Stop in /usr/src/lib.
*** [lib__L] Error code 1
Stop in /usr/src.
*** [libraries] Error code 1
Stop in /usr/src.
*** [_libraries] Error code 1
Stop in /usr/src.
*** [buildworld] Error code 1
Stop in /usr/src.

I came across this article which says :

Let's synchronise sources.


    # cd /usr/share/examples/cvsup/
    # cp standard-supfile /etc/freebsd-supfile

The list CVSup mirror sites is here.

But, the link says:

Warning: cvsup has been deprecated by the project, and its use is not recommended. Subversion should be used instead.

What should I do then? Where can I find an updated article? Should I update my ports collection?

1 Answer 1

2

You can use Subversion in basically the same way as documented for cvsup. In short:

# portsnap update
# cd /usr/ports/devel/subversion
# make install clean

Then to update /usr/src (assuming you have sources installed):

# svn update /usr/src

If sources are not already installed in /usr/src, you can check out a fresh working copy:

# svn checkout svn+ssh://svn.freebsd.org/base/head /usr/src

See Using Subversion in the FreeBSD Handbook for more options. You can get more information on using Subversion in general at the Subversion Primer.

Unless you want to customize the ports (i.e. make local changes to the source code), use portsnap. It is the official replacement for the port management functionality previously handled by cvsup and will probably meet most of your needs. See portsnap in the FreeBSD Handbook for a detailed but easy to follow guide.

5
  • won't portsnap fill the /usr/ports for various software? I'm having trouble building /usr/src
    – gideon
    Feb 23, 2013 at 18:08
  • You are correct, answer updated. I'm not quite clear on why you would take the somewhat drastic step of rebuilding world though?
    – dartonw
    Feb 23, 2013 at 18:20
  • +1 thanks for your answer. Is there any other way? My jails don't seem to work write, I can't run the ezjail-admin update -ip, which complains that I should build world.
    – gideon
    Feb 23, 2013 at 18:35
  • Ok, also (I'm somewhat familiar with svn) so /base/head/ in the svn url will point to the latest?
    – gideon
    Feb 23, 2013 at 18:36
  • "head" will be the latest, you can use svn+ssh://svn.freebsd.org/base/releng/9.1 for a specific version. It's worth noting that if you are used to csvup, the svn package has a lot more dependencies, though it has one advantage at least, you can easily checkout over http:// too. Feb 23, 2013 at 20:33

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .