1

I have an old Asus eeePC 1000H netbook with a weird graphical bug in the window-manager.

00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS/GME, 943/940GML Express Integrated Graphics Controller (rev 03)

In the past this problem was not there. But one day after an update, years ago, the weird behavor like in this screenshot of firefox title: screenshot started. It looks the same if there is colored text in e.g. vim in most terminal windows.

I tried multiple modern (=still supported) distros of GNU/Linux, but it is always there. I tried e.g. some of the *buntu familie for lower performance PCs like Xububuntu or Lubuntu, Gentoo, Debian, some Slackware based, some Puppylinux, maybe more, whatever ist the newest with 32 bit support. And also some window-manager/desktops like xfce4, gnome, lxde, mate, cinnamon, lxqt.

I also tried something like Xubuntu 16.04 LTS where the problem wasn't visible. I can't remember exactly, but it was a fairly old release. Maybe the last with GTK+2? The problem reappeard after upgrading. 16.04 is EOL and I also couldn't configure an external monitor there. So I really like to have a more modern distro. I'm not picky.

It looks as this problem is somewhat less present in LXQT with debian. So I suspect it's related to something that Qt does different than GTK+.

I tried to disable all effects in the window manager (in all I tried) but this makes the text look different but not better.

In some terminals, like xfce4-terminal, the colored text is not readable at all. Qterminal behaves good except the window title.

  • Can someone sugest a configuration option I can try?
  • Is someone still using an eeePC with a working config maybe?
  • Should I provide more screenshots or config?

1 Answer 1

0

I remember have a graphics glitch with my EeePC 901 and it was an issue similar text rendering. Unfortunately my 901 died years ago so, I cannot verify the solution.

I poked around trying to find the workaround I had used. I think it was creating a xorg.conf file and setting the AccelMethod option; what the exact value needed to resolve this issue, I don't know. Look at this page to assist, https://wiki.archlinux.org/title/Intel_graphics#AccelMethod

I cannot say for certain this will help you as you have a different model and my issue was from >5 years ago.

1
  • That absolutely did it! Thanks!!! I was struggeling for YEARS!. Jul 17, 2021 at 13:47

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .