0

I've started using Z shell on MacOS Big Sur. I changed the default shell via chsh -s /bin/zsh. When I start the Terminal I see two processes running:

$ ps
CMD
-zsh
/bin/zsh

I also see the following output when I start the Terminal program (from Applications):

Last login: xxxx
<USER>@macbook ~ % /bin/zsh
<USER>@macbook ~ %

I've moved all of my ~/.*rc files to a backup directory and continue to observe this behavior. Furthermore, I changed my default shell back to bash via chsh -s /bin/bash and continue to see similar behavior:

Last login: xxxx

The default interactive shell is now zsh.
To update your account to use zsh, please run `chsh -s /bin/zsh`.
For more details, please visit https://support.apple.com/kb/HT208050.
macbook:~ <USER>$ /bin/zsh
<USER>@macbook ~ % ps
CMD
-bash
/bin/zsh

At this point, I'm not sure what to try next. Any ideas?

4
  • Is it you typing /bin/zsh at the macbook:~ <USER>$ prompt?
    – Kusalananda
    Jul 14, 2021 at 18:27
  • No, this line shows up "automatically" when I start the Terminal: macbook:~ <USER>$ /bin/zsh Jul 14, 2021 at 18:33
  • What terminal application aru you using and has that been configured to execute a command upon startup?
    – Kusalananda
    Jul 14, 2021 at 18:53
  • 1
    I'm using MacOS Terminal (2.11). Also, it turns out that I (previously) configured my profile to run a shell command on startup. To find this, I navigated to Terminal => Preferences => Profiles => Shell => Run Command (un-check box). This appears to have fixed my issue :) Jul 14, 2021 at 19:00

1 Answer 1

0

It turns out this behavior was due to one of the profiles I had configured in the MacOS Terminal application. Navigating to the settings page and un-checking the "Run Command" box fixed my problem:

Terminal => Preferences => Profiles => Shell => Startup Section 
=> Run Command (un-check box)

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .