1

I am trying out Gentoo for the first time on my PC. It is connected via Ethernet cable.

I downloaded the minimal ISO, I booted to the gentoo kernel, then I tried running the ping command to check for internet connection, but it failed, So I check ifconfig and ip addr to check if the interface is up, and it was up, showing as enp2s0, but it was showing inet as 169.x.x.x instead of 192.168.x.x.. I also tried net-setup and dhcpcd to configure the interface, but no luck. I also tried, modprobe realtek, modprobe -r 8169 modprobe r8169 as my Ethernet is from Realtek, still no luck. What do I need to do to make it work.

2
  • Does your network have a DHCP server? DId you try setting a static IP on the interface?
    – Panki
    Jul 12, 2021 at 19:02
  • After a couple of reboots to the live USB, it worked. No idea what was problem initially. It fixed itself. But now that the system is installed, it is not assigning the correct IP, again its doing 169.x.x.x instead of 192.168.x.x.
    – apoorv569
    Jul 12, 2021 at 20:23

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.