1

I'm using Debian Bullseye on an Acer Swift laptop (I also had this issue when I was on Debian Buster).

When I have an external monitor connected via HDMI, frequently both displays (the laptop screen and external monitor) will go black for a few seconds (maybe 4 seconds), and then come back on. This behaviour is reliably reproducible any time that a website I'm on plays sounds, or I open the pulseaudio mixer dialog, and certain other options involving apps that play or control sound. When it's in response to a sound playing, the sound doesn't start until both monitors have come back on after going black.

I've read a number of questions and other discussions about similar problems, and the suggested solutions haven't worked. The only things, so far, I have found that stop this occurring, also stop sound from working.

  • Leaving headphones plugged into the audio jack don't stop this happening
  • rmmod -f snd_hda_codec_hdmi stops it happening but also disables all sound
  • Selecting a different profile in the pulseaudio (eg, to one with HDMI out and analog in) stops sound from working

It does look like it's something to do with HDMI audio. I don't want to use audio over HDMI now and would be happy disabling that if I could still have sound, if that could fix my problem.

There aren't any syslog or dmesg entries that are reliably coming up when this happens. I have a recollection that you could increase logging verbosity of the intel HDA codec, but I haven't discovered how.

Edit: pastebin of dmesg lines referring to snd_hda* https://pastebin.ubuntu.com/p/jZ3dM33PFg/

5
  • Try blacklisting (google) snd_hda_codec_hdmi instead of removing it. Also, do dmesg after boot to see what the kernel drivers think is going, so you can actually debug it. Your display driver (which one is active? Intel? Again dmesg will tell you) is probably also involved; it works together with the HDMI driver, and apparently your Acer Laptop needs special treatment.
    – dirkt
    Commented Jul 12, 2021 at 4:56
  • @dirkt it's i915 with intel DDX. What should I look for in dmesg? I've added a pastebin with lines containing snd_hda, which does show that it's ALC256, and it's "bound" with i915
    – trr
    Commented Jul 12, 2021 at 5:51
  • Please do not grep on dmesg, you are removing all the interesting parts in between. That's a pet peeve of mine, too many people do it. It's fine to see if something is in there, but you won't see any error messages on the following lines, or any context. Also please describe if this is the output with the module removed, or blacklisted, or present; or what you see during a failure. You can enable CONFIG_SND_DEBUG and recompile the kernel, but if the problem is in the Intel driver, that won't help.
    – dirkt
    Commented Jul 12, 2021 at 6:00
  • This is with no blacklisting or removal. I'm hesitant about publicly sharing an entire dmesg due to privacy. What do you suggest?
    – trr
    Commented Jul 12, 2021 at 6:06
  • I can confirm that blacklisting snd-hda-codec-hdmi does not solve the issue (and, doesn't appear to work; it looks like it's no longer loaded at boot, but looks like it's still logging various stuff as if it's loaded later)
    – trr
    Commented Jul 12, 2021 at 6:52

2 Answers 2

0

Partial answer:

To help with the debugging, you need to understand how it all hangs together. Your Intel chipset has a generic sound interface called "HDA", attached to this sound interface can be various codec chips (in your case, the ALC256). This codec will convert sound to analog, but also to signals that can be fed into HDMI. So this codec is again connected to the graphics part of the Intel chipset, where it is mixed into the HDMI audio stream.

So whatever causes blanking is related to the HDMI part that mixes video with audio. And the driver responsible for this may be the Intel driver, or the HDMI driver.

0

I hope I'm not late to help.

This hasn't happened to me on Debian, but on Fedora and OpenSuse (both using gnome) it happened. When on gnome, the only way I could get it to work was to disable wayland on the gdm conf file.

Here's the link to the same question I made yesterday. It's solved, maybe it will help you.

Screen flickers when playing sound - Solved w/ Solution

1
  • Thank you. Due to covid restrictions I haven't been back to the office to test these solutions out yet. I'm on Xorg.conf with LightDM & XFCE. Thanks for that link to a potential solution, I'll respond when I know if it solves it.
    – trr
    Commented Jul 28, 2021 at 6:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .