1

I'm a game developer, the framework I'm using has extra functions like showing information of an object on the screen, like a tree view, clicking CTRL-F1 opens this container that shows such information. I tested this on Windows and it worked perfectly, macOS too, but on my operating system which is Manjaro this function doesn't work, only another extra function is available.

These here are the functions I need and which keys they are linked to: https://github.com/ppy/osu-framework/wiki/Framework-Key-Bindings

I opened an issue in the repository, and the framework creator said I needed to find out what's consuming these keys

There is no way to change these key bindings. You will need to figure what is eating them on your system. - peppy, issue link

I can't figure out what's going on, I don't know where the key signals are going and why they aren't being sent to the game.

Here are the specs for my operating system:

Operating System: Manjaro Linux x86_64
Host: Inspiron 5548 A04
Resolution: 1920x1080
Desktop Enviroment: KDE Plasma 5.21.5
Window Manager: kwin
CPU: Intel i7-5500U (4) @ 3Ghz
GPU: AMD ATI Radeon R7 M260/M265 / M340/M360 / M440/M445 / 530/535 / 620/625 Mobile 
GPU: Intel HD Graphics 5500

Could someone help me in this problem?

2
  • Check your desktop environment's (KDE in your case) settings for the same keybinding.
    – terdon
    Jul 9 at 15:14
  • 1
    According to this list of KDE hotkeys, Ctrl +F1 is "Switch to workspace 1". I don't use KDE so I can't test it
    – roaima
    Jul 9 at 15:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.