1

I know there is a lot of posts about this problem, but i tried to find a solution every where my problem persist.. So when i want to use my wi-fi, it say: Not available, so i can use ethernet connexion only..

Here is some details of my configuration :

nmcli general status :

STATE                  CONNECTIVITY  WIFI-HW  WIFI     WWAN-HW  WWAN
connected (site only)  limited       enabled  enabled  enabled  enabled

nmcli device wifi : (It show nothing)

inxi -Fxz :

System:
  Host: lol Kernel: 5.4.0-73-generic x86_64 bits: 64 compiler: gcc v: 7.5.0 
  Desktop: Cinnamon 4.4.8 Distro: Linux Mint 19.3 Tricia 
  base: Ubuntu 18.04 bionic 
Machine:
  Type: Laptop System: HP product: HP Pavilion Gaming Laptop 16-a0xxx v: N/A 
  serial: <filter> 
  Mobo: HP model: 87AD v: 32.30 serial: <filter> UEFI: AMI v: F.10 
  date: 06/23/2020 
Battery:
  ID-1: BAT0 charge: 45.6 Wh condition: 45.6/45.6 Wh (100%) 
  model: HP Primary status: Full 
CPU:
  Topology: Quad Core model: Intel Core i5-10300H bits: 64 type: MT MCP 
  arch: N/A L2 cache: 8192 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 39999 
  Speed: 899 MHz min/max: 800/4500 MHz Core speeds (MHz): 1: 900 2: 900 
  3: 900 4: 900 5: 899 6: 899 7: 882 8: 898 
Graphics:
  Device-1: Intel vendor: Hewlett-Packard driver: i915 v: kernel 
  bus ID: 00:02.0 
  Device-2: NVIDIA vendor: Hewlett-Packard driver: nouveau v: kernel 
  bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.8 driver: modesetting unloaded: fbdev,vesa 
  resolution: 1920x1080~60Hz 
  OpenGL: renderer: Mesa DRI Intel UHD Graphics (CML GT2) v: 4.6 Mesa 20.0.8 
  direct render: Yes 
Audio:
  Device-1: Intel vendor: Hewlett-Packard driver: sof-audio-pci 
  bus ID: 00:1f.3 
  Device-2: NVIDIA vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
  bus ID: 01:00.1 
  Sound Server: ALSA v: k5.4.0-73-generic 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: r8168 v: 8.045.08-NAPI port: 4000 
  bus ID: 03:00.0 
  IF: eno1 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Device-2: Realtek vendor: Hewlett-Packard driver: rtw_pci v: N/A 
  port: 3000 bus ID: 04:00.0 
  IF: wlo1 state: down mac: <filter> 
  IF-ID-1: enp0s20f0u2c4i2 state: down mac: <filter> 
  IF-ID-2: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Drives:
  Local Storage: total: 1.38 TiB used: 229.81 GiB (16.3%) 
  ID-1: /dev/nvme0n1 vendor: Western Digital 
  model: PC SN520 SDAPNUW-512G-1014 size: 476.94 GiB 
  ID-2: /dev/sda vendor: Seagate model: ST1000LM049-2GH172 size: 931.51 GiB 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:17.0 
Partition:
  ID-1: / size: 466.31 GiB used: 114.37 GiB (24.5%) fs: ext4 dev: /dev/dm-1 
  ID-2: /boot size: 704.5 MiB used: 178.4 MiB (25.3%) fs: ext4 
  dev: /dev/nvme0n1p2 
  ID-3: swap-1 size: 979.5 MiB used: 906.6 MiB (92.6%) fs: swap 
  dev: /dev/dm-3 
Sensors:
  System Temperatures: cpu: 52.0 C mobo: N/A gpu: nouveau temp: 38 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 341 Uptime: 4d 4h 20m Memory: 7.55 GiB used: 5.19 GiB (68.7%) 
  Init: systemd runlevel: 5 Compilers: gcc: 7.5.0 Shell: bash v: 4.4.20 
  inxi: 3.0.32 

iwconfig :

enp0s20f0u2c4i2  no wireless extensions.

eno1      no wireless extensions.

wlo1      IEEE 802.11  ESSID:off/any  
          Mode:Managed  Access Point: Not-Associated   Tx-Power=0 dBm   
          Retry short limit:7   RTS thr:off   Fragment thr:off
          Power Management:on
          
lo        no wireless extensions.

tun0      no wireless extensions.

lsusb :

Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
Bus 001 Device 003: ID 0bda:b00c Realtek Semiconductor Corp. 
Bus 001 Device 002: ID 04f2:b6f1 Chicony Electronics Co., Ltd 
Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub

Also, secure boot is disabled !

It's realy boring to stay in ethernet, i can't find out from where this problem come from, i tried to install drivers ect.. never worked..

Thank for your help guys !

0

1 Answer 1

1

You have 18.04 Ubuntu base, which is old, and might be the cause of your problem.

Since you have successfully upgraded your Ubuntu base to version 20.04 of your Linux Mint using mintupgrade, and it proved me right, I am hereby posting this as an answer for others possibly looking for the same problem.

Here is one of many useful links that could help out with the upgrade process:

https://linuxmint-user-guide.readthedocs.io/en/latest/upgrade-to-mint-20.html

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .