1

I was trying to increase my mouse scroll speed by following https://github.com/tkkcc/libinput_patch which requires modifying a file. Should be easy...

$ echo 6 > /tmp/libinput_discrete_deltay_multiplier
bash: /tmp/libinput_discrete_deltay_multiplier: Permission denied

Nothing a sudo wont solve right?

$ sudo bash -c 'echo "6" > /tmp/libinput_discrete_deltay_multiplier'
bash: line 1: /tmp/libinput_discrete_deltay_multiplier: Permission denied

Checks permisions

$ stat  /tmp/libinput_discrete_deltay_multiplier
Access: (0666/-rw-rw-rw-)

At this moment I'm at the limit of my abilities. How can I change this file and why it doesn't let me change it even with root privileges? I tried many approaches and search engines are no good on this one.

Edit: Tried

$ echo 6 | sudo tee /tmp/libinput_discrete_deltay_multiplier
tee: /tmp/libinput_discrete_deltay_multiplier: Permission denied
$ dmesg | tail
dmesg: read kernel buffer failed: Operation not permitted
14
  • 1
    Does this answer your question? Redirecting stdout to a file you don't have write permission on Jul 7, 2021 at 20:25
  • tee: /tmp/libinput_discrete_deltay_multiplier: Permission denied. sadly I tried with tee already
    – welkam
    Jul 7, 2021 at 21:01
  • 1
    If it's Linux, check lsattr /tmp/libinput_discrete_deltay_multiplier. Also mount or findmnt to check what file system /tmp is (or / if /tmp is part of it)
    – ilkkachu
    Jul 7, 2021 at 23:08
  • 1
    sudo dmesg might help
    – ilkkachu
    Jul 7, 2021 at 23:08
  • 1
    Seems this one: unix.stackexchange.com/q/503111/315749. To make sure, and to also make this Q more likely to help other users, could you please add the output of ls -l /tmp/libinput_discrete_deltay_multiplier (to see the file's owner and group) to it? Also, what operating system are you using?
    – fra-san
    Jul 8, 2021 at 5:42

0

Browse other questions tagged .