0

I installed Linux Mint and connected the PC to my wifi network without problems. I updated drivers, rebooted and now there is no option to connect to wireless connections, I mean, I left-click the icon on the task bar and only "Wired" option appears.

If I open "Driver Manager", no drivers about wireless connection appear, only about NVIDIA graphic card

I've already tried (Linux Mint-17) Unable to connect to wireless network make command says make: *** No rule to make target 'clean'. Stop.

Operating System Linux Mint 20.1 Cinnamon Cinamon Version 4.8.6 Linux Kernel 5.4.0-74-generic Processor Intel© Core™ i5-8300H CPU @ 2.30GHz × 4 Memory 15.5 GiB Hard Drives 1756.4 GB Graphics Card Intel Corporation UHD Graphics 630 (Mobile) (prog-if 00 [VGA controller])

EDIT 1: Following @terdon, the output of lspci -nn | grep 0280 is:

03:00.0 Network controller [0280]: Intel Corporation Wi-Fi 6 AX200 [8086:2723] (rev 1a)

EDIT 2: The output of iwconfig is:

enp4s0    no wireless extensions.

lo        no wireless extensions.
6
  • does ip link show your wireless device? Or lspci or lsusb, depending on how your hardware is connected? Jul 5, 2021 at 16:41
  • reboot one more time
    – Andra
    Jul 5, 2021 at 16:45
  • 1
    Please don't follow random posts (especially not those from more than 5 years ago!). The question you linked to was about a specific piece of hardware, there's no reason to think it would work with yours. Please edit your question and show us the output of lspci -nn | grep 0280 which will tell us what network card you have.
    – terdon
    Jul 5, 2021 at 17:30
  • @terdon, post edited. Jul 6, 2021 at 8:02
  • Thanks. Can you also add the output of iwconfig?
    – terdon
    Jul 6, 2021 at 8:07

1 Answer 1

0

According to this page, your card is supported by kernel versions newer than 5.7. You are using a kernel version of 5.4.0, so you need to upgrade your kernel to a newer version.

Now, since your version is quite old (the current version available for in Ubuntu's repositories—Mint uses the Ubuntu repositories as well as its own—for your version is 5.10) I recommend you run a general update. It looks like you haven't run one in a while and that is not a good idea. So, either use whatever graphical tool Mint offers for updating or just open a terminal and run:

sudo apt update
sudo apt upgrade

That will bring in many updates, including a new kernel and after rebooting, you should be all set.

3
  • So I shutted down my PC and the next day the problem returned. I try to update system again but it's up to date. It's rare that my kernel version is old, I downloaded and installed de OS two weeks ago. Jul 12, 2021 at 8:19
  • @AbelGutiérrez please open a new question about that so we can see the contents of your /etc/apt/sources.list file. I checked the version in the repositories and it is certainly newer than what you are using (see the link in my answer). Maybe you didn't choose the right kernel when you booted your machine? Were you given an option?
    – terdon
    Jul 12, 2021 at 8:40
  • I posted a new question <unix.stackexchange.com/questions/658708/…> (Sorry if late) Jul 16, 2021 at 16:40

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .