1

I have several Synology NAS, running DSM 6.2.2-24922 Update 5, which I successfully mount on Ubuntu 18.04 with:

sudo mount -t cifs //192.168.x.y/folder_name -o username=user,password=???????,uid=1000,sec=ntlm,vers=1.0 /local_mount_point

I have bought a new one, which is running DSM 6.2.4-25556. I attempt to mount in the same way and I get this error:

mount: /local_mount_point: mount(2) system call failed: Operation not supported.

EDIT

I removed the vers=1.0, and the error changed to

//192.168.x.y/folder_name does not exist

Enable SMB Share is enabled on the new NAS, with the same settings as the others.

My smb.conf on the new NAS is:

[global]
printcap name=cups
winbind enum groups=yes
include=/var/tmp/nginx/smb.netbios.aliases.conf
min protocol=SMB2
security=user
local master=no
realm=*
passdb backend=smbpasswd
printing=cups
max protocol=SMB3
winbind enum users=yes
load printers=yes
workgroup=WORKGROUP

And my smb.share.conf is:

[folder_name]
recycle bin admin only=yes
ftp disable modify=no
ftp disable download=no
write list=nobody,nobody
browseable=yes
mediaindex=no
hide unreadable=no
win share=yes
enable recycle bin=yes
invalid users=nobody,nobody
read list=nobody,nobody
ftp disable list=no
edit synoacl=yes
valid users=nobody,nobody
writeable=yes
guest ok=yes
path=/volume2/folder_name_1
skip smb perm=yes
comment=""

[folder_name_2]
recycle bin admin only=yes
ftp disable modify=no
ftp disable download=no
write list=nobody,nobody
browseable=yes
mediaindex=no
hide unreadable=no
win share=yes
enable recycle bin=yes
invalid users=nobody,nobody
read list=nobody,nobody
ftp disable list=no
edit synoacl=yes
valid users=nobody,nobody
writeable=yes
guest ok=yes
path=/volume1/folder_name_2
skip smb perm=yes
comment=""

(For interest, the smb.conf on one of the NAS which are working is:

[global]
printcap name=cups
winbind enum groups=yes
include=/var/tmp/nginx/smb.netbios.aliases.conf
security=user
local master=no
realm=*
passdb backend=smbpasswd
printing=cups
max protocol=SMB2
winbind enum users=yes
load printers=yes
workgroup=WORKGROUP

)

Can anyone advise?

12
  • Remove the vers=1.0 option and try again Jul 5, 2021 at 15:16
  • That has changed the error, so progress. I now get "//192.168.x.y/folder_name does not exist" Of course I may be doing something silly now, but I've double checked everything and I don't think it's a typo.
    – Omroth
    Jul 5, 2021 at 15:27
  • For that you'll need to share your server's smb.conf. If it were a QNAP it would be under /etc/config, but I don't know where Synology keeps it Jul 5, 2021 at 15:47
  • Do I then add that as an argument to the mount line?
    – Omroth
    Jul 5, 2021 at 15:48
  • Copy the smb.conf into your question Jul 5, 2021 at 16:41

1 Answer 1

0

I was able to make this work in my case by allowing a minimum version of SMB as 1.0:

enter image description here

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .