0

When I reboot my card, the interfaces seem to be deleted from the bridge!

here is how I make the bridge work:

I create these 3 files:

/etc/systemd/network/19-gfxbridge.netdev

[NetDev]
Name=br0
Kind=bridge

/etc/systemd/network/20-bind.network

[Match]
Name=eth*

[Network]
Bridge=br0

/etc/systemd/network/21-gfxbridge.network

[Match]
Name=br0

[Network]
Address=192.168.1.33/24

I would like that the bridge binds the 3 interfaces that I have: eth0, eth1, and eth2

Here is the conf files:

/etc/systemd/network/10-eth0.network

[Match]
Name=eth0
#KernelCommandLine=!nfsroot

[Network]
DHCP=ipv4

#[DHCPv4]
#UseHostname=false

/etc/systemd/network/10-eth1.network

[Match]
Name=eth1
#KernelCommandLine=!nfsroot

#[Network]
#DHCP=ipv4

#[DHCPv4]
#UseHostname=false

/etc/systemd/network/10-eth2.network

[Match]
Name=eth2

[Network]
#Address=10.255.255.246/30

after typing: systemctl restart systemd-networkd I got the br0 on the ifconfig output but without IP:

br0       Link encap:Ethernet  HWaddr 02:3C:B0:78:B0:55
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

can0      Link encap:UNSPEC  HWaddr 00-00-00-00-00-00-00-00-00-00-00-00-00-00-00-00
          UP RUNNING NOARP  MTU:16  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:10
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:27

eth0      Link encap:Ethernet  HWaddr 50:2D:F4:1B:A3:C7
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

eth1      Link encap:Ethernet  HWaddr 52:9E:30:54:8D:EC
          inet6 addr: fd10:327e:296c:f300:509e:30ff:fe54:8dec/64 Scope:Global
          inet6 addr: fd94:e4ba:8c2a:3300:509e:30ff:fe54:8dec/64 Scope:Global
          inet6 addr: fe80::509e:30ff:fe54:8dec/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:318131 errors:0 dropped:0 overruns:0 frame:0
          TX packets:316978 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:30863912 (29.4 MiB)  TX bytes:32652232 (31.1 MiB)

eth2      Link encap:Ethernet  HWaddr 8E:2D:80:01:62:81
          inet6 addr: fe80::8c2d:80ff:fe01:6281/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:32 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:2968 (2.8 KiB)

lo        Link encap:Local Loopback
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:100769 errors:0 dropped:0 overruns:0 frame:0
          TX packets:100769 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:6159965 (5.8 MiB)  TX bytes:6159965 (5.8 MiB)

and there is no output for the command bridge link

when I run:

ip link set eth0 master br0

ip link set eth1 master br0

ip link set eth2 master br0

the br0 obtains an IP address and the output of the bridge link become:

3: eth0: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 master br0 state disabled priority 32 cost 100
8: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 master br0 state forwarding priority 32 cost 19
9: eth2: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 master br0 state forwarding priority 32 cost 19

The problem is that after each reboot I should tape the 3 commands to set the IP address of the br0. There is a way to tell to systemd to do that after each restart or a way to fix this problem without tapping the 3 commands?

Thank you!

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.