0

When I press the power button on a machine, I got log:

PM: suspend entry (s2idle)
PM: Syncing filesystems ... done.
Freezing user space processes ... (elapsed 0.003 seconds) done.

Is it suspending? not powering off?

which setting can change it?

2
0

If you are using systemd, the power button effect is now determined by logind. You can create an override in /etc/systemd/logind.conf

[Login]
HandlePowerKey=poweroff
3
  • this seems not to work for graphic mode. ( GNOME)
    – GreenTea
    Jul 1 at 2:47
  • The Redhat documentation for setting poweroff for gnome is here.
    – meuh
    Jul 1 at 18:06
  • it seems we can not do power off by pressing the power button in GNOME now (Redhat 8)?
    – GreenTea
    Jul 2 at 0:01

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.