1

Trying to set the PROMPT or PS1 variables to customise the ZSH shell prompt with the popular GRML zshrc config, it has no effect, nothing happens at all:

root@machine ~ # PROMPT="> "
root@machine ~ # 

Why is that and what can I do about it?

1

The GRML ZSH prompt system was revamped in 2013; the author's posts about it:

  1. http://bewatermyfriend.org/p/2013/001/
  2. http://bewatermyfriend.org/p/2013/002/
  3. http://bewatermyfriend.org/p/2013/003/

Post (2) explains the issue:

You will have to turn off the grml theme (and any other theme for that matter) beforehand. So your customisation becomes this:

# I want my own prompt!
prompt off
# customisation here

You can use that method, or you can use the newer zstyle based approach described in posts (1) and (3) above.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.