0

I am trying to do inplace upgrade from RHEL7 to RHEL8 using yum and ISO without amy subscription manager. This is for my development purpose and so there is no subscription attached to it. I mounted the RHEL8 ISO file as var/lib/libvirt/images/rhel-8.4-x86_64-dvd.iso on /run/media/RHEL8 type iso9660 (ro,relatime) I ran yum clean all I ran yum makecache Everything looks so good ill here. Now when I execute, yum update , I could see yum running but continuously with lines keep on scrolling as

processing dependency : xxxxxxx package version for package... ..... .... .... .... This continuous lines keep on going for 3 hours or more than that and I need to kill this process from another Shell window. I did this for 4 -5 times and still the same issue, Any idea on this

1
1

The RHEL7 to RHEL8 upgrade command is leapp upgrade - not yum upgrade.

Read the "Upgrading from RHEL 7 to RHEL 8" documentation and carefully follow the steps detailed in that document.

2
  • I came to know this utility. Can you clarify, if this leapp can upgrade using ISO packages without subscription manager. Jun 28 at 14:04
  • @VijayanandA. AFAIK, the system has to be registered to the Red Hat Content Delivery Network (CDN) or Red Hat Satellite using the Red Hat Subscription Manager. The "Upgrading from RHEL 7 to RHEL 8" documentation provides full details.
    – fpmurphy
    Jun 28 at 15:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.