1

I have a two disk synology where I had a JBOD setup (4TB and 3TB). One of the drives started becoming erratic and failed. So I pulled both of them out.

I had an automated daily backup task that would backup my important folders from disk1 to disk2.

I'm trying to gain access to both these disks from a ubuntu PC. (Connected the two 3.5inch DISKS into a Dual slot USB dock that connects to a ubuntu laptop via one USB 3 port.

I've tried to follow the instructions from synology link below, but it doesn't work. https://kb.synology.com/en-us/DSM/tutorial/How_can_I_recover_data_from_my_DiskStation_using_a_PC

Here is the output of some of the commands:

cat /proc/mdstat
Personalities : [linear] [multipath] [raid0] [raid1] [raid6] [raid5] [raid4] [raid10] 
md3 : active linear sdc3[0] sdb3[1]
      6827740928 blocks super 1.2 64k rounding

lvs
  LV                    VG  Attr       LSize  Pool Origin Data%  Meta%  Move Log Cpy%Sync Convert
  syno_vg_reserved_area vg1 -wi------- 12.00m                                                    
  volume_1              vg1 -wi-------  2.72t                                                    
  volume_2              vg1 -wi-------  3.63t       


lsblk
NAME    MAJ:MIN RM   SIZE RO TYPE   MOUNTPOINT
(truncated some of the loops)
loop17    7:17   0 161.4M  1 loop   /snap/gnome-3-28-1804/128
sda       8:0    0 698.7G  0 disk   
├─sda1    8:1    0   100M  0 part   
├─sda2    8:2    0 146.4G  0 part   
├─sda3    8:3    0     1K  0 part   
├─sda5    8:5    0   158G  0 part   
├─sda6    8:6    0  13.9G  0 part   [SWAP]
└─sda7    8:7    0 380.3G  0 part   /
sdb       8:16   0   2.7T  0 disk   
├─sdb1    8:17   0   2.4G  0 part   
├─sdb2    8:18   0     2G  0 part   
└─sdb3    8:19   0   2.7T  0 part   
  └─md3   9:3    0   6.4T  0 linear 
sdc       8:32   0   3.7T  0 disk   
├─sdc1    8:33   0   2.4G  0 part   
├─sdc2    8:34   0     2G  0 part   
└─sdc3    8:35   0   3.6T  0 part   
  └─md3   9:3    0   6.4T  0 linear 

mount /dev/vg1/volume_2 /home/user/synology/disk1 -o ro 
mount: /home/user/synology/disk1: special device /dev/vg1/volume_2 does not exist.

mount /dev/vg1/volume_1 /home/user/synology/disk1 -o ro 
mount: /home/user/synology/disk1: special device /dev/vg1/volume_1 does not exist.

Any advice on how to get this mounted correctly and access the data ?

1

Nevermind. I was able to fix this.

The steps in the link I included earlier worked just fine.

I had to follow the following steps to resolve this issue:

  1. Reboot the ubuntu system.
  2. change the boot order so it doesn't try to boot via USB
  3. keep the Drives connected via USB before the boot starts.

Once booted, I did the mount command as suggested in the link and voila, the drives were then accessible.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.